Note link breaks after renaming the linked note

links

#1

What I did:

  1. I added a link to an older note in a newer note.
    Used Right-Click > Link to: > [Select the desire note].
    I note that Agenda adds the name of the note with link embedded in the text.

  2. I renamed the older note.

  3. On the newer note, the link to the older note is broken.
    The text displayed is the old note name, still formatted as a clickable/hyperlinked text.
    But clicking on it doesn’t do anything.

What happened:
The link to the older note is broken.
Text displayed does not update to the new text.

What I expected:
The link should still work.
Better: The text displayed is also updated.

At the least (but not ideal), maybe have a message that the note might have been renamed/moved, and kindly request user to update the link?

Things that might be helpful to know (Agenda version, OS and model, etc):
Seems it might be related to this ticket:

Agenda version: 2.3 (from Mac App Store)
OS: macOS 10.13.6


#2

I doubt this is related to renaming per se. Did you move the note to a different project? If so, that will be the problem.

We are aware of this issue, and have plans to fix it.

Drew


#3

I’ve tested this issue again (renaming linked notes).

It seems to have worked fine if only rename the notes.
This is also true when renaming the linked notes in other projects.
Also tested with changing the assigned note date, just in case. Still worked fine.

However, moving the note to a different project breaks the link as mentioned by @drewmccormack.
I think I might have moved the previous note when I posted this thread/ticket.

Maybe your team can test it out. If the result is as my testing, then you can resolve and close this ticket.
Leave only moving note to different project ticket.

Thanks for the support!


#4

Yes, that is what we suspected, this is a known issue that we hope to address in the future.