Text in a note keeps disappearing

What I did:I took meeting notes during a meeting in an iPad.

What happened: New text kept disappearing. Every few seconds the screen blinked pushing the curser to the bottom of the note (even if I made additional notes to the mid part of the document). After a while I started noticing that some of the text I had previously added at the bottom of the document disappeared. Gone. Poof. This is a highly dangerous behaviour.

What I expected: All text to remain in the document.

Things that might be helpful to know (Agenda version, OS and model, etc): Latest iOS.

At the same time my mac had the same not open on Agenda for the mac. It runs the latest MacOS. Possibly this caused some kind of sync loop where the MAc constantly overwrote the iPads newer notes. I force quit the iPad app and tried recreating the problem. It came back to the app on the ipad. Later I went to my desk and created a new note from the mac, keeping it open on the mac. Then going to the iPad to edit to see if I could reproduce the error. The note intially synced to the iPad but coult not be edited. The iPad app blinked like crazy and on its own (beats me how) created a new note instead of allowing me to edit the note created by the mac. I again force quit the Agenda app on the ipad and tried editing. This time it worked and the added text was properly synced back to the Mac without problems.

Reliability in retained notes IS KEY. This is the second time notes/text disappears for me. I thought the first time was a one-off. Now my trust in Agenda has been severly damaged. I will use Apple Notes instead until you report back that this has been fixed. It seems to be a bug in Agenda for iOS.


Are you using version 9.1 on all devices?



I had the same issue once, before version 9
Seemed to be a sync problem since I had the Mac app open as well and the note changed to the version I had on the mac, ignoring my last changes

We test the app regularly with notes open on two devices, so it must be more subtle than that. We will take another look, but I fear we need more information to identify the problem.

How can I help you? What do you need to know?

I see, thanks for the answer, some bugs are hard to find
it could’ve been even a problem in my internet connection, not sure, I’m just guessing

If you can think of any circumstances which might be relevant to the problem. Eg when the problem arose, was there a lot of data that needed to come over from the other device? Did you first change a date or something?

If you are able to make this problem arise in a test note, and experiment to figure out when it happens and when it doesn’t, it would really help to narrow down where we should look. Ie rule things out.

If you can think of any circumstances which might be relevant to the problem. Eg when the problem arose, was there a lot of data that needed to come over from the other device? Did you first change a date or something?

I had a prepared note with a meeting agenda. It was a simple note with some numbered bullet points. I had previously added other comments to the same note from another iPad and these changes never made it into the note. So there might have been an existing conflict somewhere. In any case, when I started writing into the note, adding comments to bullets already in the note, the changes were committed and remain. When I added text to the bottom of the note, they disappeared every time the note ”blinked”. It took me a while to notice since I was into the meeting. But after a while I understood that text added at the bottom kept disappearing while text higher up in the document remained.

So two things I noticed:

  1. Preexisting lack of sync of information added to the note on another device (at the bottom of the document).
  2. Text higher up in the document remained, while text at the end was continuously deleted.


Also remember: the same note was open on the Mac while I tried adding / editing text on the iPad.

But the sync chain contains one Mac and multiple iPads.

Did you try quitting Agenda, and launching again? If so, did that help?

In any case, I will do a few experiments to try to reproduce it. I’m not that confident though. Often these are rare events and difficult to reproduce.

If you do find a way to just make it happen, let me know.

Just chiming in that I’ve had the same thing happen at least three times in the past couple of weeks, all while working just in the Mac OS app (though I have the app on my iPad and iPhone). I enter text and it disappears; at least twice I have come back to notes to find the content gone. I have tried to figure out a pattern for a bug report, but cannot find one…no common keystrokes, nothing about note length or location in project, etc. Sadly, I decided to move away from Agenda for this reason–gotta have the text stay in the note–but hope it will be resolved soon because the other tools just aren’t what I need.

Mac OS 10.15.1
Agenda 9.1

Did you at any stage collapse a note or have many collapsed in the same project?

Also, any chance you created a note with just an empty body and title to only later fill it in? Or create such a title only note on one Mac and edit it subsequently on a different Mac?

No I did nothing like this. The cause of missing text seems like a sync issue. I think yo use a fairly complex sync/merge logic and this is where I would start. I experimented with editing text to an existing note on an offline iPad while simultaneously changing it on a Mac. When I reconnected the iPad to the net, the additional text in the iPad document was added inside the other edits on the Mac-version of the note. I expected their to be a sync conflict and I would have to choose which version to use or possibly keep both or simply merge them simpler (one after another). But mixing text from different edits on different machines indicates a capable feature but complex one to implement. Anyway, I was a bit impressed, but the must have feature in any note taking all is reliability and that text never ever under any circumstance disappears.

Indeed we merge edits and this works well. The issues mentions here seem new. It would be great if those who reported this here could help us find the cause by sharing the following files:

  1. a screenshot of the note where the content disappeared on one of the devices affected.

  2. a zipped copy of your library:

  • quit Agenda
  • in Go to Folder under the Go menu in Finder, paste:
  • make a zipped copy of the Agenda folder, then email it or a link to an upload version (e.g. to dropbox) if it’s too large to send by email to alex@agenda.com and drew@agenda.com

Many thanks for your help!

It goes without saying that we will treat anything shared with the utmost confidentiality and will delete the files after diagnosis.

I’m sorry, cannot do that for different reasons. We will have to find a different solution.

No problem, completely understand. Anyone who is able and prepared to share their library, please get in touch. It will really help us learn what might be going wrong.

I’ll chime in and say I’ve been having problems as well. In my case the disappearing text eventually come back, after clicking away from a note and back a few times. It seems that for me, parts of notes will fail to display every time.

My problem seems to be more associated with display issues, as opposed to completely disappearing text. But seems similar!

I’ll try to create a library that exhibits the behavior and send it along. Can’t send the current library, unfortunately!

I’ve mainly noticed the issue on my Mac, running 10.15.1 and Agenda 9.1 from the MAS, synced using iCloud. Have not really noticed it on my iPad, but then again I have mostly used it on the Mac. (I tried to download the non-MAS version and see if the problems persist, but the downlink on the main page doesn’t seem to work for me.)

Yes, that sounds like a display glitch, rather than a data problem in the library. Usually restarting the app will fix something like that. Please feel free to report any issues like that. We need to know they are happening to fix them.