Syncing between desktop and iOS

sync

#21

Are you sure iCloud drive isn’t blocked by your employer?


#22

Work doesn’t block iCloud Drive. So should this work now? Previous replies said its not supported. Would be awesome if it is supported now.
I use different email addresses for iCloud Drive on the devices but logged into Agenda with the same email address on all devices.


#23

Ah that’s it, sync uses iCloud Drive and hence you will need to be logged in on all devices with the same Apple ID. The Agenda account is merely used for enabling any premium features you bought and is your access to the agenda.community, it’s not involved in syncing and we don’t have access to your data at any point in time.


#24

I can sync between desktop and iOS, but not everything syncs.

I’ve made several notes on my desktop that appear on my iPhone, but the order is all mixed up. All of the items are listed, but I placed them in specific order for a reason. I’ve tried closing the app on the phone and reopening, I’ve tried making changes, but it doesn’t change my order to match my desktop.


#25

Do you mean items in a list inside the note are out of order? Or do you mean the notes themselves are in a different order in the project?


#26

The items in the list inside the note are out of order.

I go through my recipes and list all of the ingredients for the recipes that I need. Then I put all the produce together, all the bakery items together - I don’t want to get to the dairy department and find I still need lemons on the other end of the store. I get it all set on my desktop - then when I go to use the list on my phone - chaos!


#27

I think this is a bug we have fixed, but is not released on the mac yet. Should be out very soon.

The issue arises when a list is edited on two different devices, without a sync up happening. The merging of the paragraphs can get messed up in certain cases.

We have a fix for this coming very soon. Sorry for the trouble.


#29

After verifying on both devices Agenda was set to sync with iCloud services signing out and back onto my Mac, then closing completely the app on my iPad and reopening did the trick for me.


#30

I’m still having issues after all these steps. Is syncing ability constrained by iCloud storage capacity? I want to confirm before clearing out / increasing my iCloud storage

Thanks!


#31

If your iCloud account is full then it indeed won’t sync.


#32

I’m encountering a strange synch problem where changes made elsewhere are appearing OK, but local changes are only local. I’ve verified sign in to iCloud, the Agenda is checked, and tried signing out of iCloud and back in. Perhaps coincidence, but this only started happening after I added some attached files and images. Is this a known problem?


#33

Have you got the most recent version of Agenda (4.0) on all of your devices and Macs. If one of them is using an old version, things you create on a new version may not appear there. Best to check you are fully upgraded.

Note also that a large attachment can take a while to sync over.


#34

I’ve just experienced a syncing issue between iOS and Mac Agenda. Both using the latest versions available and iCloud Drive syncing has been problem free up until now.

Basically, I created a note on my iPad and linked it to a calendar event within a specific project. This note did not sync across to my Mac. I tried restarting both apps and even created a brand new project on my iPad. The note still did not sync to my Mac, but the new empty project did.

I then moved the note into the new project and it then appeared on my Mac.

How could a note not sync?


#35

My guess is that it was just taking longer than you expected, or there was a temporary server problem. If it happens, you can try making a small edit in the note, to see if that triggers something.


#36

Thing is that other changes outside of the note were syncing fine. The note eventually synced once I’d moved it from one project to another.


#37

The sync is done on a project level. So it is possible that one project is syncing fine, while another has a temporary issue.

If it happens again, it is certainly worth restarting the device to see if that gives iCloud a shake.


#38

Saw a repeat of the syncing issues with multiple notes. It seems like I’m having a problem with notes created on iOS for one specific project (let’s call it X). Other projects are syncing iOS->Mac and Mac-iOS without a problem. Project X will sync Mac->iOS, but not iOS->Mac without me moving notes around into other projects on iOS first.


#39

Yes I checked and have the same (current) version on 3 Macs and iPhone and iPad.
Synching works fine on all but one Mac - the primary one I use, unfortunately.
I tried deleting all attachments.
I’ve tried turning off/on iCloud, the Agenda checkbox in iCloud, and the Agenda preferences item to use iCloud. Changes made on other devices synch to my primary Mac, but nothing I do on my primary Mac is reflected on any other device. It’s completely isolated - and therefore useless. Other apps using iCloud are working fine and synch immediately. Is there any way to diagnose a problem with Agenda synch?


#40

Following up on this: I’m seeing errors in the Console related to Agenda:

default 16:43:24.956006 -0800 Agenda E CloudService.swift(383) : uploadAllStores(completionHandler:) : Error uploading store: <CKError 0x600003a08450: "Partial Failure" (2/1011); "Failed to modify some records"; partial errors: { 301B2587-23F8-422C-A432-61C1B84B4A63.:(0244F12B-553C-4C90-BACB-331B7C0F4732:__defaultOwner__) = <CKError 0x600003a08c30: "Invalid Arguments" (12/1017); "Not a regular file"> ... 7 "Batch Request Failed" CKError's omited ... }>
and:
default 16:43:26.533187 -0800 Agenda E RevisionManager.swift(498) : operations(for:) : Failed to process update store <AgendaFoundation.Store:0x7fd42b902b00> (device identifier: 997009A9-F5B6-4B61-95BE-D1EE0B9D8AB1, url path: /Users/abcde/Library/Containers/com.momenta.agenda.macos/Data/Documents/Agenda/Stores/0244F12B-553C-4C90-BACB-331B7C0F4732.agenda-document) by service cloudKitService due to error: <CKError 0x600003930630: "Partial Failure" (2/1011); "Failed to modify some records"; partial errors: { 301B2587-23F8-422C-A432-61C1B84B4A63.:(0244F12B-553C-4C90-BACB-331B7C0F4732:__defaultOwner__) = <CKError 0x600003964240: "Invalid Arguments" (12/1017); "Not a regular file"> ... 7 "Batch Request Failed" CKError's omited ... }>


#42

This worked for me!

I worked on a long note during the night, then the next morning it still hadn’t appeared to sync to my iPhone.

I rotated my iPhone into landscape and boom, my note appeared in it’s entirety. Weird bug but I least I know I have access to my notes!