Syncing between desktop and iOS

No that didn’t help.
Here’s what I did that seems to have solved the problem.
I created a new project (temp project) on the Mac in the category (Main Projects) that has the project (writing ideas) that refuses to show up on iPad Agenda.
"temp project” quickly showed up on my iPad.
Then I moved the notes one at a time from “writing ideas” to “temp project” on the Mac.
All of them showed up on the iPad in “temp project” within a minute or so except one. That note would not show up on iPad Agenda. Even when I removed the content from that note, it still would not show up on iPad Agenda.
The content of the note was a reference to an item in DEVONthink Pro, with the DEVONthink item link as the link in Agenda. In other words, I selected the text in that Agenda note, used the Link To > Add Link command in Agenda, and pasted in the DT item link. DEVONthink’s item links are a very useful way to reference a particular file in DT’s database from another app.
So I deleted that note, and created a new note with the same title in Mac Agenda, but without the content or the DT link. It showed up quickly on iPad Agenda.
Finally, I deleted the project “writing ideas” from the “Main projects” category on the Mac. It was empty, but it still didn’t show up on the iPad before I deleted it from the Mac.
Then I renamed the “temp project” to “writing ideas” on Mac Agenda. iPad Agenda quickly picked up that change.
So it looks like I have a complete sync now between the two devices, although I haven’t checked everything out in detail. And it appears that the DEVONthink item link was the culprit. Not sure what to make of that. Maybe you guys can check it out. I do have DEVONthink To Go on the iPad, but I don’t think it supports DT’s item links.

One further thing. I use DEVONthink every day. If the DT item link was indeed the problem, I’d really love to have Agenda support them fully, i.e., click that link in an Agenda note and have it take me to the DT item. Maybe there is no way that this link would work in iPad Agenda right now, but I’d still like to have the note containing the DT link sync properly to Agenda on iPad.

Can you reproduce the sync issue by inserting another DT item link in a note, followed by some more edits? Do the latter no fail to sync over again?

It is very odd, and I wonder if the DevonThink link is just a coincidence. Be great if you could do a little experiment with a new temporary note and see if you can stop it syncing in the same way with a DL link.

Yes, I just tested with another note containing a DT link in a test project.
Result: no problem syncing to iPad version, very quickly. I moved the note to another project, the project including the note to a different category, and added text to the note containing the link. All of this synced with iPad Agenda with very little delay.
I guess the DT link wasn’t the issue. Glad to have it still useful. Agenda on iPad even offered to open DT To Go when I tapped the DT link, but DTTG doesn’t appear to support the item ID links that DT has on the Mac.

A post was split to a new topic: Partial and delayed sync


My phone wont sync with my Mac, i already tried signing out on both devices but wont work, mi icloud store its full, i dont know if that has something to do with it.

Hi Jonas,

Yes, if your iCloud storage is full then sync between your devices won’t work as the new data can’t be stored.

Hi, Mark. How can I catch errors from Console? With which software?

Use the Mac Console app - /Applications/Utilities/Console. You can filter message on “Agenda” to find messages specifically from that application.

Hope that helps,

  • Mark

Got it. Thank you:smiley:

A post was split to a new topic: Not syncing with iCloud

I think that regardless the age of this thread, it’s something that keeps coming up. I got the same problem for months and tried several things. So today I took some time and stayed focused until I resolved the issue. I don’t know if everyone’s problem is the same, but I think what I write will potentially help at least some of you so it worth your time reading…

  • My problem: I have a MacBook, an ipad and an iphone. For some reason it wouldn’t update the iCloud version of it from any device. So I was naturaly afraid to login/logout etc because I was afraid that it will syncronise an earlier version and I’d lose a lot of new data
  • What I did:
  1. My most updated version was in my MacBook (master device). So I selected all my notes and I exported them in every available export file type just in case.

  2. I did the sign-in and out in all devices, nothing changed. But I kept ALL DEVICES signed in during the rest of the procedure. (I also deleted/downloaded/installed the app in all devices. The issue was still there)

  3. I checked the iCloud drive and for some reason it wasn’t connected (its a DIFFERENT procedure than signing in at icloud with the correct account!!) [If you don’t know how to do it, go to spotlight, write iCloud Drive, select it and then click Connect iCloud Drive, put your iCloud user/psw, done]

  4. I unsyncronised (from the agenda settings) all the other devices i.e. iPad and iPhone, selecting to keep data in iCloud

  5. I closed the agenda in all other devices EXCEPT the “master” one, the one that has the valid Agenda data. I kept them closed until I completed next 4 steps.

  6. I unsynchronised the master device as well, also selecting to keep data in iCloud (same to step 4). I then deleted the app in those devices (as a precausion, maybe this wasn’t necessary) downloaded it/ installed it and checked that Agenda was logged out. BE CERTAIN all other devices except the maste one is logged out and not synchronised with iCloud otherwise this solution won’t work!

  7. I synchronised the master device and DIDN’T close the settings window (I mean the window where you select to synchronise the Agenda with the iCloud) till it had downloaded all info from iCloud.

How do you know that data is being dowloaded? Next to the iCloud button, I saw a small cloud indication with a blinking arrow (having a downward direction). I let it download everything, i.e. when the little cloud disappears.
This may take some time… it took me 30 mins, but it depends on how much data you have in Agenda…
8. Unfortunatelly, I got a lot of dooble Categories and notes. BUT, the ones on top are always the older version ones. But please CHECK it yourself too. So, by comparing them, I deleted all the duplicates, leaving my Agenda clean and unto date. Also before going at the next step, check whether it is still uploading data. Only when all data has been uploaded to iCloud you can continue with the next step.
9. Now I logged in my iCloud account in Agenda at my first device and then synchronised it to iCloud. It then started to download the freshly uploaded from the master device iCloud backup. Let it for sometime to download all data. In case that it seems done, but there’s still info missiong, then just close the Agenda at that device (NOT the master device one), open it again, unsynchronise it and synchronise it once more. It took me 2-3 times for each device…
10. Follow previous step for next device etc

I hope this works for you as well!

1 Like

Thanks for sharing and apologies you had to go through such a painful process, iCloud can be really unwieldy sometimes alas.

1 Like

All of the above has all to do with your icloud interface - you could learn something from CRAFT which arguably has by far the best of all apps and that includes Apple themselves.

If you’re comfortable with storing your notes on this app’s servers yes, in our case we’re indeed dependent on Apple’s iCloud integration, which means we can’t access your notes something we feel better about, but has as a downside that we can’t control the details to the extend other developers can that store your notes on their servers.

2 posts were split to a new topic: Trouble with Sync

Wow! Worked for me too.

Great solution. I had a similar problem and went through similar steps. Luckily, in addition to my iPad and iPhone, I had a second Mac.

  1. Similarly, backed up everything from my main MacBook; including the directory from the Group Containers (in ~/Library).

  2. I then disconnected the main MacBook from iCloud syncing.

  3. On my iPhone, iPad, and MacMini I deleted and re-installed Agenda - and logged in to each app with iCloud syncing enabled.

  4. At this point, my iPhone, iPad, and MacMini were all sync’ed via iCloud but with no projects. To test the sync, I created a project on each device to ensure it was picked up by the other two devices. All was good.

  5. This step was the tedious bit. On my (main) MacBook, I would grab several projects at a go from the left-hand-side menu and export them as an Agenda file. I would then AirDrop this file to the MacMini and import in to Agenda. I would grab several, but not all, at once as I noticed that Agenda file exports did not include Category information - just a few projects at a time made it easier for me to manage the import process as some of my projects have same name but live in different categories, and I also use sub-categories. All the while I was checking that the imports were syncing nicely to the iPhone and iPad.

  6. When this was all done, I quit Agenda on the (main) MacBook, I deleted (which was already backed up!), restarted Agenda and then turned iCloud syncing back on. All done!!

Some observations

  • I’ve been using Agenda 2019 and suspect my data was clobbered. Pre-clean up it was 2GB; post-clean it’s 800MB
  • if a project is, or contains a note that is, Locked then it can’t be exported or have its order changed within a category or moved to a different category until it’s unlocked
  • Agenda file exports don’t include category (or sub-category) details
  • syncing with iCloud is really quick - I’d always thought syncing ‘sometime during the day’ was normal. Nope - very, very quick.

To the Agenda team - thank you! LOVE this app!

1 Like

Sorry you had to go through all that. Glad it did work out in the end.

We have seen iCloud itself have issues independent of Agenda over the years. Sometimes, if you simply sign out of iCloud on the device, and sign back in again, it clears the corrupted data on the device, and it all works OK again. It is certainly worth trying that if the sync seems really stuck (eg not syncing for many hours, even with the app in the foreground).