Spelling Corrections

textediting

#1

What I did: Spell checker functionality irritatingly bad

What happened: When a word is incorrectly spelt it is highlighted with a red underline. To check the spelling or to add/ignore the word you have to highlight the whole thing using your mouse. Most other Apps only require a right-click of the mouse to bring up the contextual menu.

What I expected: Just to right-click and underlined (mis-spelt) word and be able to Add/Ignore

Things that might be helpful to know (Agenda version, OS and model, etc): macOS High Sierra 10.13.6. Agenda Version 2.5 (42)


#2

Thanks for the feedback. We will see what we can do.


#3

That’s not what I’m seeing, you do however have to make sure the note is selected. If I right-click on a word with the red-squibbly line (just in the middle, without selecting the whole word) it works just fine with me. Can you find a pattern under which this doesn’t work?


#4

Thanks for your response. Please see a couple of screenshots

  1. The note is selected and I have ‘right-clicked’ the red-squibbly line. You will notice that the spelling options are greyed out as is the option to Ignore Spelling, Learn Spelling etc.

  1. Here I have highlighted the word by ‘right-clicking’ and dragging. The spelling options plus Ignore Spelling/Learn Spelling are now available.

Kind regards

Phil


#5

Thanks Phil. Indeed, you have to select the word yourself first. Some other apps will select the word automatically when right clicking. We will see if we can support this in future.

Drew


#6

Thank you


#10

I was unaware of the spell-checking facility because mistakes are not underlined. There isn’t a setting I can find to turn on checking - is there one?

MacOS 10.14
Agenda version 2.5 Mac App Store
Dark Mode


#11

There isn’t a setting I can find to turn on checking - is there one?

You find it here:


Autocorrect and Notes Import
#15

Thanks. I’m going to get my eyes tested today - I just didn’t spot it.

Ken


#16

BETA 4.0
Great to see the improvement in the spell-chek functionality. Previously a mis-spelt word had to be highlighted with the mouse, now its just a case of right-click and the word gets highlighted automatically.

Excellent stuff chaps.


#17

Glad you like it!


#18

all those options are disabled for me.

I have following. Could you help? Appreciate it.

  • Agenda version: 4.0 (MAS)

  • OS X version: Version 10.14 (Build 18A391)

  • AppKit version: 1671.0

  • Device type: MacBookPro15,1

  • Device ID: ec10e5f0-9a4d-462c-8c21-a43cac863902

  • Agenda account: lutian.ci.personal@gmail.com

  • License status: Current (expiry: 2019-12-31 03:48:26 +0000)

  • Projects: 11

  • Sync: Enabled

  • Other devices: 3


#19

You need to put the cursor into a note before trying to use the menu items. Those items are for the currently selected text, so first you need to select some text (put cursor in) and then it should work.


#20

It worked. I thought that setting is at the app level instead of note level. Thanks for the help. Appreciate it.


#21

Is this feature supposed to be the ‘same’ in iOS? I’m having issues with it and the contractions (like dont and isnt) while using the external Apple Magic keyboard.


#22

Are you perhaps using the first v5 test version, it had a bug with autocorrect that should be fixed in the one from yesterday.


#23

No. I’m using the latest Beta.


#24

I just tested this on our latest build, and it seemed to work for me. I typed “dont”, and it become “don’t”. I typed “don” and then could select “don’t” instead. Both seemed fine.

If you are still having trouble, can you double check the build you have, perhaps wait for the new beta that is coming in a hour or two, and if it still has issues, give me explicit instructions on how to make it “break”.


#25

I can’t get dont to work. Wont happen. Doesn’t does. Cant see why. :wink: And that’s with screen keyboard. Will test with Magic keyboar later.


#26

Just got v57. See screen grab-