Reverting notes

I’m just trying to retrieve an earlier version of a note from a backup, but that folder doesn’t exist. Has it changed where I need to look? There are three “Agenda” folders in ~/Library/Containers, but it’s not obvious to me where the notes are stored in those

EDIT: I have found the folder, but is there any way to identify the file for the specific note I want to restore?

There is no easy way to read the data. It is not for human consumption.

We do have a tool that might help. Agenda keeps a history internally, and we have a tool that allows you to go back in time on a note.

  1. Quit Agenda
  2. Run the LibraryReverter tool you can download from
  3. Navigate to, and select, this folder:
    ~/Library/Group Containers/
    There is a single space after “Group”, but no other spaces.
    (If you can’t find it, use CMD-SHIFT-G and copy the whole file path in.)
  4. Select the project in the list you wish to restore content for
  5. Select either a specific note or all notes for that project
  6. Select the time from which you want to restore any deleted content or notes (this means anything deleted after the time you select should reappear)
  7. Click on restore
  8. Launch Agenda.

Please note that all we can do is undelete any paragraphs and notes, which means some data may appear that was originally deleted on purpose. For example, if I first delete a few paragraphs in a note, then add a new line. When I now restore using this tool you will see all of the paragraphs reappear. This can mean that you might have to do some cleanup and editing to get the note all back in the right shape. But at least the content should be back.

Thanks, when I tried this there we notes or time-points to select from, regardless of which project I chose.

When I quit the tool and tried again I got this error:
The operation couldn’t be completed. (AgendaFoundation.LibraryManagerError error 0.)

I tried again on a different Mac and while the tool launched, I still got the error of not being able to select any notes or restore points. When I try to restore “All” from “-” it just gives me an error sound

I have now simply rewritten what I had lost from the notes, so while the solution didn’t work it is now “resolved”

Sorry about this. It seems our tool needs an update.