Repeated Crashes on macOS

The last thing I did before crashes: dragged an Alias to an .html file into a note

What happened: it crashed (with a bug type: 309 - according to the Apple crash report.

It crashes reliably every time I open it immediately on opening

What I’ve tried:

  • deleted and reinstalled Agenda (from website) - nb Hazel deleted support files and I left them in trash on reinstall
  • gone into iOS and deleted the project that I last updated.
  • iOS and iPadOS versions seem ok.

Things that might be helpful to know (Agenda version, OS and model, etc):

  • macOS Monterey 12.0.1
  • M1 mac mini, 2020
  • Agenda 13.1.1

I’d really like to know asap how to recover Agent to being functional.
I presume it syncs every time a new record is created?
perfectly happy to lose the last update
but now I’m using Agenda as my primary note taking tool - this is a disaster !

Sorry to hear this. Did you send in the crash reports when you next launched the app? That might tell us what is going wrong.

Probably the best way to handle this is to revert the problem note. Agenda keeps a history internally, and we have a tool that allows you to go back in time on a note. I recommend doing that, going back to just before the link was put in.

  1. Quit Agenda
  2. Run the LibraryReverter tool you can download from
  3. Navigate to, and select, this folder:
    ~/Library/Group Containers/
    There is a single space after “Group”, but no other spaces.
    (If you can’t find it, use CMD-SHIFT-G and copy the whole file path in.)
  4. Select the project in the list you wish to restore content for
  5. Select either a specific note or all notes for that project
  6. Select the time from which you want to restore any deleted content or notes (this means anything deleted after the time you select should reappear)
  7. Click on restore
  8. Launch Agenda. The deleted content should appear again (this can take up to 30s). It’s possible some notes will be in the Trash, if you moved them there before deleting them completely.

Please note that all we can do is undelete any paragraphs and notes, which means some data may appear that was originally deleted on purpose. For example, if I first delete a few paragraphs in a note, then add a new line. When I now restore using this tool you will see all of the paragraphs reappear. This can mean that you might have to do some cleanup and editing to get the note all back in the right shape. But at least the content should be back.

I may have found your crashes. Very odd though. Never seen a problem like this.

Try the reverter I mentioned, but it may not work. The problem looks very deep in the data.

If your iPhone/iPad is OK, perhaps try this on the Mac:

  1. Quit Agenda if running
  2. Click on Finder, choose Go > Go to Folder, and enter ~/Library/Group Containers. Drag the folder to the Trash
  3. Click on Finder, choose Go > Go to Folder, and enter ~/Library/Containers. Drag the folder Agenda or com.momenta.agenda.macos to the Trash (if either exists; they may not)
  4. Launch Agenda, and let it sync up.

Kind regards,

We have a theory about this. Is there any chance you could tell us the name of the alias you dragged in? Would need to know the full name, including file extension. You could get this by using Get Info in Finder, I think.

Hi Drew
that worked many thanks (the reverter as you surmised didn’t)
(I sent today’s crash reports, in case that detail was needed)

Just hunting the Alias

HI Drew
sorry the alias was deleted, and isn’t in the “bin”
I’ve searched the safari history & whilst I’m reasonably certain the website I was visiting, I don’t seem to be able to recreate the same actions to generate the alias
FWIW it was a site about programming the Micro:bit (a grandfather/grandson project)

OK, thanks for trying. Glad you have everything back up and running!

Kind regards,