Persistent bug adding empty checklist items

What I did:
Create a checkbox list in iOS.

What happened:
Agenda on macOS and iOS adds empty checkbox items randomly, but persistently. Now seven empty to-do list items and counting.

What I expected:
One empty checkbox list item after hitting enter.

Things that might be helpful to know (Agenda version, OS and model, etc):
This appears to be a live iCloud syncing issue in context with creating list items while apps on multiple devices are open simultaneously (but only one device is used for entry/editing at a time).

Are you using version 9.3.1? We fixed a bug in 9.3 that sounds what you describe, make sure you update to 9.3.1 on all devices that sync.

Yes, all devices use the current release. It is normally just one additional list item it adds. But today it went on overdrive and kept adding empty list items every couple of seconds. Deleting them resulted in them popping back up. Only when I closed Agenda completely on all devices it stopped.

And you are absolutely sure none of your devices is still on Agenda 9.3 instead of 9.3.1?

Yes, every device uses the latest version. There is no update pending on macOS and iOS.

However, I did notice one difference: There is a MacBook that uses High Sierra, not Mojave. I can’t update the OS on that computer, because it’s the last version that uses Logic Pro X plugins that are no longer supported by Mojave.

I need to correct my previous statement. The MacBook in question also runs on Mojave, so all operating systems are on the latest version and all installed Agenda apps are 9.3.1 as well.

Same issue, reallly irritating, fix please

I am unable to reproduce this on any of my devices or Macs. I was seeing it a lot on 9.3, but for me, 9.3.1 has fixed it.

Can someone who has this issue please prepare some detailed steps so that I can try to reproduce it? I need details (eg is it always the last line of a note; does it happen immediately or only after you come back to the note later etc)?

Also, please triple check your iOS Agenda version. You can find that information by opening the right panel, tapping the settings button bottom-left, and then tapping on About Agenda at the bottom. It should say Version 9.3.1.

Thanks in advance!


Ghost Entries in Lists

The phenomenon is still ongoing and extremely irritating, up to the point where Agenda becomes unusable, because you end up going through several hundred ghost entries. Interesting is that when you put the marker at the very last one it just created and hit “delete”, it will delete all ghost entries at once – only to start adding them again right away.

A second part of this strange behaviour is, while you are writing inside a just created list item, the pointer will jump erratically and cause wrong entries, which then you try to correct, during which the cursor jumps yet again on the same line, causing even more errors.

In addition to the first part of a seemingly limitless amount of empty ghost list items, the fact you can’t correct your own entries makes it impossible to use Agenda effectively.

Circumstances and Conditions

  • Latest version of macOS
  • Latest version of iOS
  • Latest version of Agenda on all devices
  • Three Macs (one MacBook Pro 15" private, one MacBook Pro 13" business, one MacBook)
  • Two iOS devices (one iPad Pro, one iPhone 11)

All devices are logged in with the same iCloud account and are using the same Agenda account.

Is there a way to access an app log on the Mac? I would be willing to locate it with the Terminal and send it to you, if it exists.

When and how does it happen

  • Immediately after the last entry was made, as little as one second later
  • When the page is idle (no editing at all), just sits there by itself and Agenda keeps adding ghost entries
  • Ghost entries seem to use black numbers, not bright grey, in dark mode
  • Ghost entries can be deleted at once when the text selector is placed in the last item (you have to be quick to beat its automated ghost entries)
  • Ghost entries can only partically be deleted if the selector is placed somewhere in one of the rows of ghost entries

Where does it happen

It seems to happen across all devices, so when I’m looking up the same list on my iPhone, it shows up there as well, including the ghost entries, but sometimes the numbers differ (MacBook Pro has 105 ghost entries in idle, whereas iPhone has created only 76).

Thanks for the detailed description, we believe to now have found the cause and have hopefully fixed it, it will be part of the next update. Many thanks for helping us fix this issue!

1 Like

Thank you for persistently following up, hunting and fixing this bug. It is much appreciated and will make a huge difference in working with Agenda.

1 Like

I managed to find and fix this yesterday. Will be in the next beta.

If you can’t wait that long, I can send you a link to a copy with the fix.

The way to avoid this issue is to not have empty list items at the end of a note. That, in combination with sync, is the cause.

Great that you have found the source of the issue. However, it didn’t matter where I placed the text marker. Also, if there was an empty list item or not did not make a difference. I’ll see if this behaviour has changed once the new version will be released.

I just tested this with the current version of Agenda, to see if it’s true what you said about the empty last list item. Since yesterday night I hadn’t opened Agenda on the MacBook Pro. My last list note showed 376 empty (numbered) list items. I deleted them all and placed the marker at the last entry item, so there was no empty list item available. After one second or so, Agenda created another empty list item.

I also tried to delete that last list item and reset it to paragraph, to have no list item as the last item of the note. Still, after a second the system placed another ghost list item under the list and deleted my empty paragraph.

Additionally, I tested adding content after the list (a paragraph of text right after the list, so the last list item isn’t empty). Still, the system created another empty list item by itself.

Currently there is no way of stopping ghost list items being created indefinitely. I think even if I close all open instances of Agenda on all devices, it will still continue to create empty list items.

It would be great if you could send me the link to the beta download. I can’t stop Agenda from creating list items endlessly. No matter what I put under the list, it keeps growing.

This morning I had a business call and I was taking notes in Agenda during the call, creating a checklist. Agenda soon started creating empty checklist items again.

At some point I needed to change a previously entered item two rows higher in the list. I changed it, then the curser suddenly jumped down to create yet another empty checklist item and my text since the two rows was deleted.

This is no longer just an annoying bug, it is destructing content. My notes since item four on a 10 point list is gone.

Does restarting the app bring back the missing items?

Note that if you have these reproducing items, you probably have to completely remove them to fix the issue in that note. I have a feeling they will continue to reproduce otherwise, even in the new beta (like Disney broomsticks).

Did the beta help at all? That wasn’t really clear to me.

Note that as long as you don’t have an update on your iOS devices, there is a risk they could be doing it. The issue does at least begin with sync. That seems to be the initial trigger.

My comment was written before I had installed the update which you sent me yesterday. I have installed it now and for now the problem seems to be contained.

Restarting the app did not solve the issue I described, the list items were gone for good.

Deleting all empty instances is what I have always done throughout the course of experiencing this problem, I also created new, empty notes, copy pasted the existing content into those, but the result was the same, it kept adding empty items.

There’s a lot strange with these empty list items the program creates by itself: they don’t seem to be on the same line as the marker. When you place the marker inside the list with empty items, it seems off. In Dark Mode, dashes and numbers of list items are shown black (on black on iPhone), so only when you activate that note (tapping on it), the background lights up, revealing those dark numbers and dashes. Then deleting individual empty list items does not work, you only can delete them all at once by putting the text marker at the very end of the list. You have to be quick, as it keeps adding empty items continuously.

I am glad the fix seems to work so far, but I fear this problem may have a different source than just the last list item generating an endless loop of copies.