Native on-the-fly spell check, keyboard shortcuts not working

spellcheck
textediting

#1

Native on-the-fly spelling correction and keyboard shortcuts do not work in Agenda. Just about every Mac application supports on-the-fly (meaning, as I type) spelling correction. Words are highlighted and automatically corrected, e.g., if I type “thier” every Mac app will automatically fix that to “their." None of this is working in Agenda and it’s very annoying, as I rely on it to both fix spelling, and streamline my typing.

Keyboard shortcuts also don’t work. When I type two hyphens, I should get an em-dash (because I have that keyboard shortcut defined). Alas, Agenda doesn’t do the right thing. This is really slowing down my text entry as I find myself backing up and fixing things a lot… :confused:


#2

Have you setup the settings in Edit > Spelling and Grammar, and in Edit > Substitutions. There are a bunch of settings there, and maybe you need to toggle them.

Drew


#3

I have the same issues, inc. text replacement.


#4

Can you both confirm that it doesn’t work despite having the options enabled under the edit menu? please note that live spell check only works in the note that is actively being edited.


#5

Ok… 50% success.

I didn’t realize I had to turn on live spell check. Suggest you make that “on” by default – as all other Mac apps do.

HOWEVER… Even after turning this on (and making sure just about every other text-related option is on), I’m still not getting any keyboard substitutions or replacement, e.g., – does not turn into — and my table-flip shortcut tbf does not turn into this… (ノಠ益ಠ)ノ彡┻━┻ … although it does in this web page… heh…


#6

In terms of replacing dashes, that is a separate option under Edit > Substitutions. Did you activate that?

If it still doesn’t work, can you try restarting your Mac, and then again checking those Edit menu settings?


#8

To @mekentosj

Cc @drewmccormack

Yes I can confirm. To recap, A few things are not working properly sometimes.

  • Some I mentioned before:

  • I also noticed that the font changes (to this one below and I don’t know its name) while typing text after inserting emoji characters. If I delete the text and type again, it is all back to normal. It happens also in Evernote.
    22

  • two spaces after text replacement to activate tag (link) - I believe one should be enough.


#11

@drewmccormack,

Ok, I had to fiddle around with it to get a good diagnosis. So, first off, 1) yes, the substitution options are turned on, and 2) I’ve restarted Agenda, etc., etc.

Expected behavior: When I type any shortcut, such as two hyphens, Agenda should convert it to my assigned value (an em-dash in this case). So, “–“ turns into “—“ and other shortcuts, like “tbf” turns into “(ノಠ益ಠ)ノ彡┻━┻”. Also, if I enter a typo, Agenda should use the Mac’s spell check and autocorrect common mistakes, like changing “thier” to “their”.

Actual behavior: The keyboard shortcuts and correction only happens if I type v e r y s l o w l y.

I’m a pretty quick typist, probably 80+ wpm. If I type at my natural rate, none of the substitutes occur. If I slow down to a painfully slow rate… maybe 10-15 wpm, they work.

So I would say this appears to be some kind of performance issue, perhaps? FYI, I’m running on the latest edition MacBook Pro (literally about two months old). I don’t think it’s the machine…

ALSO:

Spelling / grammar does not stay enabled. It seems that every time I start Agenda, I have to go and turn these options on. Why not default them to on or, better yet, remember my selection??

ALSO:

Automatic spelling CORRECTION suffers the same performance problem. For example:

Typed normal speed: The qiuck bronw fox jmped over the lizy old dgo.

Typed v e r y s l o w l y: The quick brown fox jumped over the lazy old dog.

Note how the second one had all the typos automatically corrected. FYI, this performance problem only seems to affect the Agenda note entry fields. For example, here’s the above typed directly into this forum post, again, I’m typing with the typos but notice that it is automatically corrected, at full typing speed:

In forum post, full speed: The quick brown fox jumped over the lazy old dog.


#12

OK, thanks for narrowing it down. This gives us something to test. Will look into it.

BTW, my settings for spelling do seem to stick OK. These are stored in the preferences, which can get in a corrupted state at times. Perhaps a reboot will help that aspect. Also note that you only see the settings when you have a text area selected.

Drew


#13

Thank you @zac, I was able to reproduce the issues we both face with text replacement and spelling.


#14

Have been able to reproduce this, and have fixed it in the 2.1 update.

Thanks for reporting the issue!
Drew


#15

Another bug:

If I just have “Correct Spelling Automatically” ticked, then Agenda doesn’t correct spelling automatically. You must also have the red underlining feature, “Check Spelling While Typing” ticked in order for autocorrect to function.

Running version 2.2.1


#16

Thanks for reporting!