Losing attachments when moving notes between projects

attachments
ios

#1

I am losing attachments in notes that are copied/moved to other projects

What I did: Note with an attachement is created in a project (“Project1”). Using either drag and drop or move command from withing note, the note is moved to a different project (“Project2”)

What happened: In project1 the attachment thumbnail is an icon with a series of lines. After the note is moved to Project2 the icon changes to a “cloud”. Clicking on it the attachment from that point on does nothing- nothing open and the file is effectively lost.

What I expected: the attached file would move with the note without any change.

Things that might be helpful to know (Agenda version, OS and model, etc):
On current versions of ios and agenda on an iPad Pro. Attachements are sent to notes using x-callback links via shortcuts. I have not noticed file loss in notes that were not moved.


#3

I have the same issue.


#4

This is a known issue. We will have a fix soon. Sorry for the trouble.


#5

Any thoughts on when? I hope soon- this. If breaks my workflow- the data loss makes Agenda currently unusable. Or- is there a temporary work around you can share?


#6

I plan to have this fix in the next release, probably a week or two from now.

For now, if you avoid dragging notes to other projects, you should be OK. You can move them within a single project.


#7

Hi Drew. I’ve just installed beta version 4.1(64) and this issue still seems to exist. I think it was listed as fixed in the release notes.


#9

Yes, going to investigate. It was supposed to be fixed, but perhaps it depends on whether you drag or move etc.


#10

Hi! New update just came through- issue still exists- I checked both dragging or choosing move from menu. Both cause the issue. Tested on iPad.


#11

We’ve indeed narrowed down what was causing this but it didn’t make the cut to the 4.1, it should be fixed in the next update.


#14

We believe we have fixed this in the upcoming 4.1.1 update, please let us know if that’s not the case.


#15

Just got 4.1.1. Still broken. On iPhone (will try iPad later). When I move a project with an attached pdf using the menu move… (will try drag and drop on iPad later), the pdf icon changes to a cloud and the file is gone. When I move it back to the original location the link is restored and the file again accessible.


#16

OK, thanks. We will investigate this.


#17

Confirmed same behavior on ipad and with both dragging and choosing “Move to…”. Moving a note causes its link to the file to break… moving it back re-establishes it…


#18

Additionally- for debugging- the notes were created and files attached in iOS using x-callback url.


#19

The problem that a link to a file breaks when moving to a different project is a separate issue which we know about. Unfortunately, that one is a bit harder to fix, requiring changes to how we store data. We will try to get to that too, but we will fix the moving of attachments in the short term. (Was actually supposed to be fixed already, but there were a bunch of unanticipated complications.)


#20

Hi- new version just came through- nice update! The release notes mention a fix for files that get lost in the move- unfortunately it did not provide the fix for this issue.

Note created and file saved to Agenda using x-callback in to a project called Inbox-attached pdf is confirmed to be there (icon shows lines)
note is moved to difffernt project… icon changes to cloud and file is no longer visible.
note moved back to inbox- pdf becomes again visible

Is there something I am doing wrong?


#22

Was the note created a while ago, or was it new after the update? It is true that older notes can still experience the issue.

If you make a small edit in the problem note, eg adding a space, and wait 10 seconds, I think you should then be able to drag it and have it work.

Sorry for the trouble.


#23

Thanks…

I found a partial solution…

  • new note is created and file saved with x-callback- file has an icon with horizontal lines.
  • if the move menu item is chosen (to move the note to another project) the note moves and the icon for the file changes (to a cloud)- and the note is lost. If I then move the note back to its original position, the note is restored (as is the icon)
  • if I drag the note, the icon also changes (this time to a paperclip) but this time the file is maintained and is viewable in the new location.

So it would seem that dragging does something different then the menu choice.

What do you think?


#24

I’m a new Agenda user and saw this issue today when reviewing a note from last week. I have a “logbook” project that I use for notes that I’m not actively working on. A note in my “logbook” wasn’t showing any images that I’d attached to it.

Steps I took to resolve:

  1. Find a note with broken attachments.
  2. Move that note back to the original project.
  3. Observe that the attachments are restored.
  4. Move the note to the desired location, in my case that was the “logbook” project.

Presumably, the above steps imply that the fix applied in the update works for me.


#26

Hmm, so maybe the Move To is broken and the dragging is not. Is that what you are saying?

Is it possible that simply the act of moving the note in the first place effectively triggered a save, which fixed any issues, so that the second time you tried, it worked? It’s a bit difficult to say, I guess. I will do some tests.

Let me know if you find a reproducible problem.