iOS13 is on the Agenda 🎉

We’re pleased to let you know that today’s Agenda 7.0 release for iOS brings full compatibility with iOS13, including support of the new features of the Reminders app, such as the ability to add sub-tasks, but also integration with the system wide dark mode. We’re also introducing a new black theme to the premium pack, which is ideal for devices with OLED screens.

Another exciting new possibility as part of iOS13 is the ability to scan documents with your phone’s camera straight from within Agenda. Scanned document appears in the text, can be previewed, and automatically syncs to other devices. Make sure to give it all a try after you’ve upgraded to iOS 13 through the iOS App Store.

Update: We have just released Agenda for iOS 7.0.1 with additional improvements and fixes.

Introducing integration with iOS13’s system wide dark mode, and the new document scanner interface.


I much prefer the previous dark mode where it was a dark grey. The new dark mode is simply black and makes the white text look too bright and uncomfortable to read. Is there any way of downgrading to older version?


I’m afraid we’re following Apple’s system colors, the only way the old theme is available is if you choose dark mode while the system wide setting is “light”. We’ll keep an eye out whether this is a common sentiment, if so we might offer the previous theme as another dark mode option.

A post was split to a new topic: App icon shortcuts

Well, the „scan document“ feature of iOS 13 appears rather useless to me because it does not OCR PDFs, thus make it searchable. Like it is now, it just a photo in a PDF document.

So I still rely on Scanner Pro which does the job properly.

I love the scanner feature but the Agenda is very buggy on iOS 13.1, which I upgraded to (by mistake…). The most annoying problem is the switching to other Notes just during swiping through the list of notes.

Another one is an inability to check the checkmark.

Another bug is very strange haptic behaviour when editing a note – iPhone is getting haptic feedback by moving or shaking the phone only! It stops after ending the edit mode.

I am using last iOS 13.1 beta on Pro 11.

Well, the „scan document“ feature of iOS 13 appears rather useless to me because it does not OCR PDFs, thus make it searchable.

So far we have no search inside attachments for any kind of attachments, in that sense it’s not different. In fact, Agenda does in fact do OCR and add even a text layer to the PDF if you export and open it in a different app. We also hope to add attachments indexing for search in a future update.

We just got informed by another user that the latest beta of 13.1 indeed introduces some unfortunately interaction issues when it comes to triggering menus and gestures :frowning: We’re investigating these as we speak.

1 Like

I am glad you are investigating it. Thanks.

Similar problem occurs when mouse-scrolling through notes in Agenda for Mac on Catalina 10.15 Beta (19A558d). It unintentionally scrolls back to the last edited note where the active cursor/focus was placed.

I am trying to reproduce some of these issues in the iOS 13.1 beta.

Can you elaborate on the checkmark issue. I seem to be able to hit them, but occasionally they seem to detect two hits, so they check, and then uncheck. Is that what you are seeing?

Re: haptics. I am noticing a haptic tick when I make my iPhone horizontal. It is quite odd. Not sure what could cause that.

I think iOS 13.1 is extremely buggy. Not sure these issues are problems in Agenda, or just in iOS. I will see if I can determine the cause and fix if there is something I can do. Any extra details are certainly welcome.

Thank you for your attention to user complaints :slight_smile: I noticed the update in AppStore which improved the behavior. The checkmark now works, the strange haptics is gone. Another important and annoying problem has not been solved yet – tapping/scrolling problem:

  • whenever I try to swipe up/down through notes, I have to check if my finger is properly placed on the note without a URL, because…
  • the first tap (even without lifting my finger) on a row containing URL leads to opening the URLs
  • there is no way I could swipe/scroll a bit the content when hitting the „URL row“ by finger first, the opening behavior is immediate
  • typical behavior for scrollable/swipeable content with hyperlinks (e.g. Facebook, Safari etc.) is that the app waits for user’s finger next move: lifting it is considered as tapping on link, moving is considered as swiping gesture without opening the link

As I am often heavily using the link in the notes, the Agenda is sometimes completely unusable now – it feels like „finger mine field“ for me.

Touching the app anywhere in the red rectangle (without additional gesture or lifting the finger) leads to opening the URL link in a row/paragraph:

PS: I updated to public iOS 13.1 yesterday and the bug is still there.

1 Like

This is happening for me as well. Super frustrating to use the app in current state. Nearly impossible to navigate as my notes are very link heavy.

1 Like

This is fixed. It will be in 8.0.1 soon. Sorry for the trouble.

Thanks @drewmccormack

Bad news: it is good when scrolling. But the touch sensitive area around URL link is still so big that it partially overlaps lines/rows above and below. Just try it. I cannot tap (and start editing) in a row in between lines which are made of URL links without unvoluntary tapping and activating one of the links. Even with line spacing set to 55-60 %. :frowning:

@drewmccormack This video shows my tapping on iPad Pro (iPadOS 13.1 with public beta) on word “naplánuje”. Line spacing: maximu. I did it repeatedly and tried to touch the lower part of the second line (baseline). It opens the link above.

Ok, now I see there are another problems:

  • the “touch URL area” is even so wide that there is no way to check checklist without opening the link in case the item start with URL
  • browsing through notes where is image/PDF present is again a nightmare, because you cannot use the area of image/PDF preview for swiping as it opens the wholescreen preview of the image/PDF without lifting the finger

Hi Mekentosj,
I’d like to purchase Agenda for iPadOS and macOS in the meantime.
Please send me the coupon code.

Heartfelt thanks,

Unfortunately the large URL tap area is something that all apps have, also Apple Notes for example, it’s not within our control. We have filed a big report with Apple and hopefully they will address this in a future update.

1 Like

We’re indeed looking into applying the same fix as we did for URLs, thanks for reporting.

1 Like