Can’t create links to email any more

export

#1

I’m trying to do the same thing as discussed on Email in Agenda, but I’m having a different problem.

What I did:

  • Dragged an email message into an Agenda note.

What happened:

  • The subject of the email appeared in the note without any link to the email message.

What I expected:

  • a link to the email message.

Things that might be helpful to know (Agenda version, OS and model, etc):

  • Agenda version 2.3
  • MacOS High Sierra version 10.13.6
  • I also tried dragging an email message to Omnifocus which I know for sure used to work and it did the same thing.
  • I also tried to create a link by following these instructions, but the “%"s in the link kept changing to “%23”s and the links wouldn’t work.
  • I tried dragging a file into Agenda to see if that would create a link and it did. When I clicked the link, it opened the finder and selected the file. I did the same in Omnifocus; in that case, double clicking the file opened it in Preview, as it was a jpg.

So, I’m giving up and asking for help. :slight_smile:

Thanks!


#2

Odd. I just tested this, and it seemed to work fine.

Can you try restarting the app, and then doing it again?

Are you just using Apple’s Mail app, or a different one?

Does this problem happen with all notes, and all emails? Can you try a few different notes/projects, and also different emails, and see if there is some trigger causing it to go wrong that we could narrow it down with?

Drew


#3

Ok, it seems to be that one email. I tried 4 others and those worked fine. I can also click on the links and the links work fine repeatedly – I tried repeatedly since my manual link kept changing when I tried to use it.

I noticed that the instructions in the article I found said to put “message:%3” before the message id and “%3E” after. I noticed in the working links, it had “message:%3C” before the message-id. When I tried that, I was able to create a link to this particular email message; it now reads:

message:%3CPRODJOB06Npo8doyAIa000d2cec@outside249.iship.com%3E

I can send the entire email to you privately; if you’d like, just let me know how (what format; I can copy/paste it into a message here or use email). It looks like a pretty normal html message to me. As you see above, the message id starts with a bunch of letters instead of numbers like most do, though I’m not sure how that would matter. I did find a message that started with F41E726D, but that worked fine.

I tried a new note in another project and category, but I got the same behavior: this one email message didn’t work but others did.

Thanks again!
-Liz


#4

Interesting. The %3C is a code for a < symbol (see https://www.w3schools.com/tags/ref_urlencode.asp).

%3E is >

So the system must expect the id to be in <id here>

If I understand right, when you drag this email to Agenda, you get the subject, with no link at all. Or do you get a link, but it doesn’t work? If you do get a link, what link URL is it after the drag?

I think the likely reason for this is that the identifier used for that message is somehow an email address. Perhaps that is confusing the system. Perhaps it is a corrupt identifier.


#5

I get the subject without any link. For most messages, I get the subject with a link to the message and it works fine. For this one particular email, I just get the subject.

I was experimenting with the links to see if I could create the link by hand, and that worked, once I figured out the %3c thing. I realize now that without the C, this one was %3P which would have confused the parser since it wasn’t hex.

Once upon a time, I knew a lot of ascii codes for symbols, but apparently, not so much any more! I think they usually looked like #3c, though. Can you still type “ascii” to Unix and get the table? Just tried it; you have to type “man ascii”. I must have had an alias or something.


#6

One other question, does the email you drag have multiple emails in a thread? These don’t work due to limitations of what Apple places on the clipboard. It only works with the individual emails in a thread.


#7

I’m just dragging a single message. It’s one that I got from a UPS store with information about something I mailed from there. It was not in reply to anything and there are no replies to it.


#9

I got another email from the same shipping place and its message ID looks much the same as the earlier one. However, when I drag it to Agenda, it works fine. So, I guess it’s not the PROD stuff in the ID after all. This one’s link reads:

message:%3CPRODJOB07btnLGhLQYk000fdcdf@outside249.iship.com%3E

The message itself looks a lot like the earlier one; just some of the text is different. I tried again to drag the earlier message into Agenda, but that still doesn’t work. I just looked at the raw source of both messages side by side for a couple minutes and there’s nothing obviously different in them, except what you’d expect, like different dates. I didn’t see any spurious special characters either, though I’m not sure how “Raw Source” in Mail would show those.

At this point, I’m sort of shrugging this off, as I don’t think it’s an error in Agenda. My offer to send you the message stands as there’s nothing in it that I wouldn’t mind you seeing, if you want to pursue this.

-Liz


#10

It sounds like some corruption in Mail app TBH. Let’s mark it down as a one off and move on. Thanks for helping us investigate!