Appending text to a note via shortcuts doesn’t seem to work consistently

What I did:

  1. I run the following URL via shortcuts: agenda://x-callback-url/append-to-note?title=Title&text=Text&project-title=Project&on-the-agenda=false.
  2. I see notes getting appended, which is good.
  3. Then, I delete some text on the note using my keyboard directly on the agenda app. Looks good.
  4. I run the shortcut again with a different text. The new text gets appended to the note as expected.
  5. The stuff that I deleted on step 3 still exists.

What happened: Deleted text reappears

What I expected: When I delete something, I expect it to be deleted.

Things that might be helpful to know (Agenda version, OS and model, etc):
Agenda: 4.1.1
iOS: 12.1.3
iPad Pro 2017

Looks similar to the issue described here: https://agenda.community/t/lost-images-from-my-notes/27742/2v and here: Text layout corrupted with extra blank lines

So, will wait for the new version then.

Yes, this sounds indeed like it’s the same issue. We’ve submitted a new version and asked Apple for an expedited review. Hopefully it will be out soon.