Wrong info in menu („Show/Hide Sidebar“)

bug
sidebar

#1

Hello,
I hit „Alt-Command-S“ to hide and show the (left) sidebar. I did this a few times in a row (without doing something else like editing notes“) and suddenly only „Hide Sidebar“ (and not anymore „Show Sidebar“) was listed in the menue - no matter if the sidebar was shown or not.
I tried to reproduce it now but it did not happen again.
Maybe it depends on where the focus is (in the notes area or the sidebar) or how show/hide the sidebar (via keys or choosing the menue).
Greetings,
Claus


#2

Thanks for letting us know, we’ll try to reproduce.


#3

There technically is no ALT key on a Mac keyboard, but I assume this is the Option-Command-S combo?

I just tried about 50 times with my cursor in various parts of the screen (in sidebar, in a note, in the body of a note, in the title of a note, etc, and on my computer it faithfully opened and closed the sidebar as prescribed with no ill side effects. I couldn’t reproduce.

If someone else can reproduce please pass along how you did it.


#4

I think there was likely some sort of internal crash, which then caused subsequent commands to fail. Makes it difficult to reproduce.

BTW, my iMac keyboard includes both the text “option” and “alt” on it, so I suspect Apple accept both now.


#5

I tried it again but all looked fine. No way to reproduce it, so I guess the problem was not connected to Agenda.
@kkathman: There is an ALT key (even two, on both side of the space bar key) marked with „alt“ - on my Apple keyboards, even on the MBP 2016.


#6

Something different but connected to the side bars. I can choose "Show/hide Todazs Calendar“ and „Show/hide Related“.

  • No right side bar visible (-> in the „View“ menu „Show Todays Calenda“ and „Show Related“)
  • Choose „Show Related“
    -> Now the right menu is visible (incl. “calendar”!)
  • In the menu should be „Hide Today’s Calendar“ (instead of „Show Today’s Calendar“ as the calendar item is shown already).
    Now choosing "Show Today’s Calendar“ results in no changes, also the menu entry "Show Today’s Calendar“ does not change to „Hide Today’s Calendar“.

I hope my explanations are clear …


#7

I see what you mean but it’s not exactly what this menu command does. The idea is that it’s not so much a toggle to show or hide the section of the related panel with the calendar, but a shortcut to bring the displayed date back to today (in case you use the calendar or arrow buttons in the header, or have a note selected with a different date than today). Therefore if the related panel is already visible and it is already showing Today, there’s no work to be done. Technically it could be greyed out at that point I guess.


#8

Yes, it should be greyed out.
Only a cosmetic thing … not so important :-).