Workflowy to Agenda Shortcut - need help

I’ve started using Workflowy as a quick entry text input app, because it’s cross-platform (Windows/web/iOS), lightweight, and has a cool interface. It’s centered around bullet-style outlining, which is normally how I take notes anyway. I am trying to write a Shortcut to export a Workflowy note into Agenda, and I’m close to making it work but there’s some weird stuff going on with the formatting. Specifically, when it gets to Agenda the indentation levels are getting goofed up when I have multiple levels of indentation (more than 2). I can’t figure out for the life of me why, since when I look at the text using “Quick Look” inside of Shortcuts, the indentations look correct.

EDIT: I tried putting in indented text from other sources (Drafts) and am having the same issue, so I think it’s on Agenda’s side, not Workflowy’s.

Here’s the Shortcut as I currently have it: https://www.icloud.com/shortcuts/42b8e6a204dc4867917916ae10607e9f

If anyone has time and uses Workflowy or is willing to quickly download it on iOS, and try sharing to this shortcut (by swiping a Workflowy note to the right and selecting “Share”) to see if you have the same issue, and/or if anyone has tips on how to fix this, I’d really appreciate it.

Thanks.

How is the text indented exactly? I have a feeling we don’t recognise text indentation in markdown, so that may indeed be the reason. We would have to improve the importer.

Here’s what the text looks like in Markdown (confirmed by “Quick Look” in Shortcuts right before it hits the URL scheme):

  • Tab 1
    • Tab 2
      • Tab 3
        • Tab 4
          • Tab 5
            • Tab 6
              • Tab 7
                • Tab 8
                  • Tab 9
                    • Tab 10

And here’s how it comes out in Agenda:

Hmm, so Agenda does show indentation, but not the right indentation.

In the markdown, are you using spaces or tab characters? Could be Agenda just assumes a tab is 4 spaces, when you are using 2 spaces, or something like that.

I was just using tabs for each indentation.

I will investigate. Thanks.

I’ve investigated this a bit. Import of markdown text does correctly preserve tabs, so it is probably something to do with the shortcut usage. I note that you allow rich text. There is a good chance that will get messed up, since markdown is a plain text format.

My advice would be to only allow plain text, and see how that goes. If it still doesn’t work, can you post here what the URL looks like before it gets called to open Agenda? The tab characters should be percent escaped in the URL.

The only Markdown-related options in Shortcuts are “Make Markdown from Rich Text” or “Make Rich Text from Markdown.”

If I import plain text without using a “Make Markdown…” step, this is what I see in Agenda:

And this is the URL that generates: agenda://x-callback-url/create-note?project-title=Inbox&title=Test&text=Test%0A%09%E2%80%A2%091%0A%09%E2%97%A6%092%0A%09%E2%96%AA%093%0A%09%E2%96%AA%094%0A%09%E2%96%AA%095%0A%09%E2%96%AA%096%0A%09%E2%96%AA%097%0A%09%E2%96%AA%098%0A

If I instead try to run that plain text through the “Make Markdown from Rich Text” action first, this is what I see in Agenda:

And this is the URL that’s generated: agenda://x-callback-url/create-note?project-title=Inbox&title=Test&text=!%5BAttachment.png%5D(file:///Attachment.png)%0A

EDIT: I just tested the first Shortcut in this post with a bulleted list from Bear rather than Workflowy, and it came through looking correct. So it seems that the issue probably lies in how Workflowy exports its text. That’s really frustrating because I want to use Workflowy for a variety of reasons, but this is a big roadblock. I’ll try talking to them. I think this is probably not Agenda’s issue after all. In the meantime, does anyone have good recommendations for plain text editors that sync between Windows, Mac, and iOS? :slight_smile: