Widgets blank on macOS

What I did: Added a widget (any size or configuration)

What happened: A widget appeared, but it is completely blank - no notes show up in any setting.

What I expected: Some of my notes to appear, e.g. those scheduled for today, attached to events today and on the agenda

Things that might be helpful to know (Agenda version, OS and model, etc): 13” M1 MacBook Pro on macOS 12.3. Widget works ok on my MacBook Air with the same OS version.

That is very odd. Can you send a screenshot of the widget.

Here are some things to try:

  • Click on Edit Widgets, remove the widget, and add it back
  • Make sure you have opened Agenda at least once, and it has some notes
  • Click on Edit Widgets, edit the widget (flip it over), and make sure the eligible notes are “All”.

Let us know if that works, and we will investigate more if needed.

Thanks, attached some screenshots. Agree it’s weird - the widget works fine on my other macbook (not synced to this one).

I have plenty of notes, some attached to events (that happen today), some have “today” as their date and some are #due(today), so I’d expect at least some of these to show up.

I’ve tried removing/re-adding the widget, restarting Agenda etc. Only thing I haven’t tried is a full reboot, but I’ll do that next when I can.

As a sidenote - if there really are no notes to display, maybe the widget should display a message to that effect - “No relevant notes found” or something like that. Maybe Agenda already does this when the widget is working.

Yes, it does show a message if there are no notes: “No Relevant Notes”. At least, that is what is supposed to happen.

Can you try the full reboot? If that doesn’t help, perhaps you can try this:

  1. Quit Agenda
  2. Click on Finder
  3. Choose Go > Go to Folder
  4. Enter this ~/Library/Group Containers/WRBK2Z2EG7.group.com.momenta.agenda.macos/Release/Application
  5. You should see a folder called DerivedInfo. Drag that to your desktop (don’t copy it — move it)
  6. Also drag the folder called Widgets to your desktop
  7. Launch Agenda
  8. Throw away the old widget, and add a new one.

Looks like a full reboot fixed it - working as expected now. Thanks!

Odd. Glad it is now working at least.
Kind regards,

1 Like