Using a lot of battery and CPU

uses a lot of battery power and CPU

There are times when the app needs to sync, and at those times it can use quite a lot of CPU.

Do you see the CPU used continually, or just sometimes?

We have plans to address performance and efficiency as soon as we are done with images and attachments, which is very soon.

Hi @drewmccormack, is there any development on this issue? I didn’t make specific measurements but can confirm a quite high battery consumption across multiple apple devices.

We have a new version coming out at the end of this week. Can you perhaps upgrade to that and let us know if it is still a problem?

Agenda does need to do regular syncs, so this can lead to more battery use than some other apps.

Kind regards,

+1 for significant CPU usage. At 98% or above in activity monitor with my fan spinning constantly.

We’re sorry to hear about that, could you do the following when the application starts freezing/spinning:

  • open the Activity Monitor app (which you find inside your Applications folder under Utilities)
  • select Agenda (it should appear in red) in the list of applications
  • take a sample (using the button in the toolbar)
  • email us the sample report to

That should allow us to see what the app is doing while it hangs.

Also, does the (which you also find inside your Applications folder under Utilities) output any Agenda related error messages?
Best wishes,

This issue seems only exist in a version downloaded from apple app store.
I download from website directly, and the problem was gone.

I tried this, uninstalled the app store version and installed the version from the website. Can confirm the battery utilisation is less, my MBP fans don’t spin anymore.

However, I notice all my notes post 30th sep have disappeared - I need some help to recover those. they aren’t in the bin and i’ve tried switching dropbox sync on and off but to no avail. Can anyone help me on this?

Could it be that simply reinstalling the app was clearing the problem, irrespective of whether it was the app store or website version? Have you tried going back to the MAS version?

Hmm, that’s not good, can you email to start a separate discussion?

Just sent across an email.