Unusable on iPad

What I did:
tried to use the left and right pull-out menu.

What happened:
Left hand menu. Only half the menu is visible. Unfortunately it is the right had side which is mostly white space.

Right hand menu, only half the menu us visible. In this case the menus is functional because it is the left hand half of the end which is visible.

What I expected:
Works fine on my iPhone 11, but menus don’t work properly on my iPad rending it unusable.

Things that might be helpful to know (Agenda version, OS and model, etc):
Agenda version 9, iOS 13.2.2 , iPad Air 2

Hmm, that is odd indeed. Have you tried quitting the app, by double clicking home button, and swiping it off the top of the screen?

Does rotation the screen change anything?

The bug persisted in both landscape mode and portrait mode. That was this afternoon, at work. Now I am at home and it is working ok.
The only difference is the connection speed, I am connected to my home WiFi which is very fast. At work, it was connected to the iPhone 11 which was my personal hotspot, very poor 4G speed. Could this be the issue?

It very much sounds like a layout glitch, let us know if it returns