Undo and Redo performance

performance

#1

What I did:
Undo or redo any typing.

What happened:
Agenda has 1-2 second pause before performing either. Behavior itself is correct. This happens even in new/enpty project.

What I expected:
Instantanious undo and redo.

Things that might be helpful to know (Agenda version, OS and model, etc):

  • Agenda 2.3 (40)
  • macOS 10.13.6 (17G65)
  • Late 2013 MacBook 15” 2.6Ghz, 16 RAM

#2

Yes, we are aware of this, and would like to improve it. Unfortunately it is quite a major change, but we will get to it.


#3

Experiencing the same on iPhone. In fact, any typing is incredibly (in the order of seconds) sluggish.

  • Agenda 2.3 (40)
  • iOS 11.4.1 (15G77)
  • iPhone 6 (64GB)

#4

Is it even slow to type in a new note? Could there be some background sync going on?


#5

No - no background sync going on. My phone is a few years old and can be a little sluggish opening new apps, but once running, Twitter and Spark for example, are just fine. I feels like the editor functionality in Agenda doing a lot of work.


#6

And it is slow for a new, empty note too? Or just large notes?


#7

Hi Drew - just as slow with small notes. In fact I just noticed that it is also very slow to create a new note (> 2 secs).


#8

Yeah, that is certainly broken. It should be just as fast as Apple Notes, certainly with small notes.

Do you perhaps have a lot of Calendars? Eg. Are you using Agenda on a work network where everyone shares a calendar?

Drew


#9

There are a lot of work calendars but I only have three enabled with Agenda.


#10

The undo can be slow, and we are aware of this and have plans to address it. But typing should not be slow. We would like to know why that is.

Perhaps you can try this:

It would really help us if you could gather some extra information while the problem is occurring. If you would like to help us track down the issue, here is what you can do:

  1. Quit Agenda
  2. Open the app Terminal, which is in /Applications/Utilities
  3. Copy this into Terminal, and press return
    defaults write ~/Library/Containers/com.momenta.agenda.macos/Data/Library/Preferences/com.momenta.agenda.macos enableVerboseLogging -bool true
  4. Run Agenda and trigger the problem
  5. Quit Agenda
  6. Open the app Console, which is in /Applications/Utilities
  7. Select your Mac top left in Console
  8. In the Search field, type Agenda, and search
  9. Select all the lines on the right
  10. Click the share button next to the search field (the button is a box with arrow)
  11. Choose Mail. Send the email to drew@agenda.com
  12. Go back to Terminal and copy in this command, and then type enter.
    defaults delete com.momenta.agenda.macos enableVerboseLogging

We would really appreciate this, and it could help us track down the issue.


#11

No problem Drew, but the problem is with Agenda on iOS - you still want me to do this?


#12

If the problem doesn’t existing on the Mac, no, there is no point doing it there.

So the Mac is fat for editing, but he iOS app isn’t? And the iOS app is slow on all your iOS devices?


#13

Yep, Mac is fine for edition - it’s just my iPhone that’s causing problems - I’m afraid I don’t own any other iOS devices.


#14

I guess you could try deleting the app and installing it again on iOS. Make sure that if you do that, you first have all the data on your Mac.

Here is a clean up routine you could try:

  1. Delete your iPhone app
  2. On the Mac, go into the Agenda > Preferences and turn off sync, and choose to remove the cloud data
  3. Turn on sync on the Mac again
  4. Install on iPhone

Drew


#15

I followed those instructions - thanks Drew. Once it synced (might be useful to have some kind of syncing indicator) it looked great - very responsive. Seems to back to normal.

As an aside, maybe you need to consider forcing users to select one or more calendars rather than enabling all of them by default - it’s a bit of a pain going through all the calendars to disable the ones I don’t want to link to.

Thanks again.

ct


#16

Glad that helped. A mystery why it was messed up.

Do you have a lot of calendars? I do wonder if this was caused by that aspect. Most people just have a few, so it makes sense to include them all, but sometimes people have many from colleagues.

Drew


#17

Thanks Drew. I have about 20 calendars (shared from some of our team) but only have one (mine) enabled within Agenda.


#18

Just wondering if perhaps before you are able to turn off the extra calendars, Agenda has already started importing all those extra ones, and that causes the issue.

Drew


#20

I was thinking that might be a possible cause Drew - that’s what was driving my suggestion not to enable all calendars by default (well it was my gut that was driving the suggestion as opposed to any knowledge of how Agenda works :-))

As an aside, turning off calendars is very slow - there’s a long delay (4-5 seconds) between clicking the switch to toggle off a calendar and the switch state changing to the off position. Apart from the delay there’s no visual feedback that something is happening.

ct


#21

OK, thanks. We are going to think about this one. Perhaps we need to guard more against the exploding calendar problem.

Drew