Underline (_) removed

textediting

#1

Hi,

First thank you for the great App. I have noticed when I type the underline character (many of my folder names have underlines in their names) they will be removed and the remaining string is reformatted. Seems to bee some kind of Markup reformatting. How can I make this stop?
An example: I type: 00_raw_data. What I get is: 00rawdata with the raw in italic.

Best,

Philipp


#2

Hi Philipp,
Yes, that is a markdown shortcut.
You can avoid it by either using the preformatted paragraph style, or using inline fixed-width style. You can get the latter by hitting CMD-L or using back ticks, like this `Test_with_underscores`


#3

Hi,

Thanks for the reply. I would really like a possibility to disable this. Especially when copy-pasting from other apps (e.g. Terminal) this behaviour gets really annoying. And, there is no way to get back to the original (with underscores) by changing the style once it is converted to italic. The paragraph has to be formatted already before.

best,

Philipp


#4

Thanks for the feedback. We will consider how we might improve this.

For now, as a workaround, if the text you are pasting has underscores, you are probably best to change the paragraph style to “Preformatted”, and then paste. That should preserve everything.