Unable to open scans

What I did:

Tried to open a scan in my notes - I tried double clicking and ‘open’

What happened:

Screenshot 2022-05-30 at 10.29.19

What I expected:

Open scan

Things that might be helpful to know (Agenda version, OS and model, etc):

Version 14.1.1 (231) - Mac App Store

MacOS 11.6.6 (20G624)

Oh, odd. Do you know when you added the scan? Was it an old one or recent?

Do you remember the steps you took to add it to the note? (I assume it was from that device, right?)

It’s happened again right now!

The flow is:

  • scan doc into Agenda Note on iPhone
  • open Note on Mac
  • try to open scan on Mac
  • get the ‘can not open’ alert

The Preview works on the scans on Mac.

I can open the scans on my iphone.

And the scans are really PDF files? Did you markup at all, or were they pure PDF scans?

Does this happen every time, or just sometimes?

Does it matter if you wait a few minutes before trying to open on the Mac?

Kind regards,

Yes, all pdf scans, with no markup.

I’ve restarted both my Mac and iPhone before further testing, but the same problem.

I only stated making scans in the last few weeks. I’ve found one scan that does open, but I can’t see what’s different about it. The rest don’t open.

Also, I’ve now discoverd that when I drag them to emails as attachments, they are added to the email, but when I go to my sent emails, and try to open the attachments, I get the same error message. (I’ve not heard from any recipients that they can’t open them)

I have now experimented with scanning (on iPhone) into a note that already exists on the Mac, a newly created note on the iPhone, typing into the note before and also after making a scan, no typing at all. I still get the same error.

I’ve tried closing Agenda on the Mac while scanning, then waiting 10 minutes before opening Agenda on the Mac. Same error.

:slightly_frowning_face: :slightly_frowning_face:

I’ve tried to find a scan in the Finder. I searched on the name I’d given a scan in Agenda, and found the pdf - I can open this pdf. (The same scan is also found in my sent folder for Spark email in the Finder - but there it has the name I gave the scan in Agenda. I can also open these scans.)

I also found the same scan by searching on a word that is in the scan, but not in the name I gave the scan. It seems the scans have been OCR’ed.

Here’s the location of the scan if that helps:

OK, this is getting weirder. It seems to be a Mac problem, not an Agenda problem:

When I navigate to pdf document on the web in Safari, and right click to open the pdf directly from the browser window, I get the same error message. But if I download the pdf to my downloads folder, I can open it with no problem.

Good news for the Agenda team, but I’m stumped!

UPDATE: Others seem to be having this issue with pdfs in MacOS 11.6.6:

Hopefully will be fixed in an update.

1 Like

Thanks for letting us know and investigating so thoroughly. We’ll hold off a bit on investigating, as it does seem to be a. system problem.

I guess you can’t update to macOS 12, or don’t want to, right?

It’s on my to do list!