Text is stuck in fixed width format

format
textediting

#1

What I did:

  1. I typed in fixed width text: sample text.
  2. I pressed backspace/delete to change “text” to something else.
  3. I pressed enter/return to start a new line.

What happened:

  1. All text from the new line onwards remained in fixed width format.
  2. The fixed width text could not be re-formatted either.
  3. I could not change the style to body or heading using the formatting hotkeys.
  4. I could not change the style using the menu options either.

What I expected:

I expected the ability to change the formatting after modifying the fixed width text and entering a new line. However, the text remained stuck in fixed width style.

Things that might be helpful to know (Agenda version, OS and model, etc):

Agenda version 1.2 - Mac App Store
OS version 10.13.3
MacBook Pro (15-inch, Late 2016)


#2

Hello,
I can confirm the same behaviour. Yesterday I was trying all the Markdown formatting options available and could see the same effect when using the backticks. I had to delete the whole block of text to be able to use other formats again.


#3

This is correct behavior. Fixed width is similar to bold or italic. It is an inline style, and it carries over paragraph borders. You need to toggle it off again.

If you want a single paragraph that is using fixed width font, I recommend using the preformatted paragraph style.

Drew


#4

BTW You can remove the fixed width format, just like you remove bold or italic. Ie select the text, and choose Fixed Width again. It will toggle off, and remove the style. That is the same as bold or italic or other inline styles.

Setting Body paragraph style will have no effect, because the text in the paragraph has the inline style applied. You have to remove that inline style to see normal text again. It’s just like making a whole paragraph bold.

Hope that explains.


#5

Thank you, Drew. I did not realize that fixed width text is being handled the same way as bold and italic text, but now it makes sense after reading your posts.

Removing the fixed width format worked. I found the hotkey (Command+L) to be useful too. I will remove the “bug” tag since this is working as expected.


#6

The “bug” here is that Agenda isn’t working as users expect. There is no indication of “Fixed width mode” other than that the text is in a different font (which one might recognize as “fixed width”, but might not).

Other rich text editors use a “Clear text formatting” option to clear things out entirely, and give some affordance - ex, a checkbox in the menu item, or a change to the menu item’s text - to indicate that selecting Edit | Fixed Width will clear a setting rather than set it.

I added a feature request for a “Clear text formatting” option.


#7

Note that the latest release does highlight the Fixed Width menu in the Format menu. So you can see when it is on/off. There is a checkmark when it is on.


#8

Apologies. Seems we added the checkmark for the paragraph styles, but somehow neglected to do it for inline styles like bold and fixed width. Too much on our plates here.

We are working on this code soon to support the touch bar, and will address it at the same time. Sorry for the trouble.