Sync issues with Agenda 16

Hi! I am experiencing sync issues between devices. Currently running Agenda 16.0 on the Macs and 16.1 on phones (iOS). I had been experienceing this under prior versions of Agenda and read that a cause of this was being fixed in 15, I believe?

I’m not sure what to do at this point. I don’t want to lose any of the data I have on the laptop side or the mobile side, if possible.

I also can’t seem to figure out if there is any way to see what the server is storing on each note, to determine whether one device isn’t syncing properly or they all are.

Can someone help? THANK YOU!! :heart:

Usually, this is simply a case of giving the device enough time to upload/download the data. You could hold Agenda in the foreground for a while, just stopping your device from going to sleep, to give it time. If you don’t want to to have to constantly keep the device from “sleeping”, you can turn off the Autolock in the Settings.

Repeat this on each device, letting it sync for around 20 minutes. Usually that will allow everything to upload and download, and it will be fast after that.

Note that you can see if it is syncing by looking for the clouds crossing the islands icon (or flashing cloud icon) at the bottom of the right panel. It appears when there is sync activity. On the Mac, this appears top-right in the window.

If that doesn’t help, here is what I recommend:

  • Turn off the sync in Agenda on each device.
  • It will ask if you want to remove the cloud data. Do that
  • Wait 10 minutes
  • Now turn on the sync for one of the devices, and let it finish uploading. The cloud will flash in the right panel, or on the window, until it is done. Can take a bit of time, so you might want to disable sleep or autolock
  • Once it is finished, turn on sync for another device, and again wait until finished
  • Repeat for last device.

Thanks. It wasn’t doing any updating, regardless of how long I left the apps open and in the foreground. Here’s what happened as I followed the steps you provided:

  1. Turned off sync. The work laptop (the device most often used for Agenda) gave an error, “Could not remove data from iCloud: Agenda was not able to remove the existing data from iCloud. You can delete it manually.” The other two devices turned off sync OK.
  2. Turned on the work laptop, waited for the syncing icon to complete. Then the iOS device, then the home laptop. After some time, the iOS device and home laptop synced, but the work laptop never did (it’s data still is unique from the other two and did not change).

I think there is something further in the work laptop that is not getting it to sync with iCloud. This device is logged into the same Apple ID as the other two, and currently is running OSX 15 like the home laptop is (I haven’t upgraded the work laptop yet, and the home one can’t upgrade to OSX 16 Ventura). Running Agenda 16.1 on the home laptop and the iOS device, Agenda 16.0 on the work laptop (the App Store on the work laptop doesn’t show that there is an update available for Agenda yet to 16.1).

How do you troubleshoot something like this further?


I think there is something further in the work laptop that is not getting it to sync with iCloud.

Are you sure your corporate network/laptop allows talking to iCloud at all? I know some corporates don’t. Do other Apple services, like syncing things in the Notes app work for you on that laptop in the corporate network?

Yes, all other iCloud services work on it without a hitch. Our workplace doesn’t install added stuff onto the laptop, it’s just a work provided laptop. And Agenda historically has worked, it’s only been in the last month or two that the syncing has become really problematic.

It’s very odd that Agenda 16.1 doesn’t appear in the App Store for you. It has been out for weeks. Perhaps try signing out and into the App Store, see if that triggers something.

Note that iCloud can be blocked by businesses without installing anything. They just block the network for that service. Not saying that is it, but could be.

So you see nothing happen on the work laptop at all? Do the clouds move over the island top-right? If so, that indicates it is still busy syncing. You could give it a bit of time.

If that doesn’t help, does your work Mac have data that you don’t have on the other devices? If so, it is a lot, or could you export it and move it to the other devices? I ask, because a next step might be removing all the Agenda data on the work laptop, and seeing if it will sync up then.

Kind regards,

I had similar issues both with Dropbox and iCloud.

Read this thread on how I solved it.

1 Like

Thanks everyone. I did finally get it solved. After resetting it, I left Agenda open and active on the work laptop all day, and then all of a sudden several hours later, it displayed the data on the server.

This is the second time this has happened in the last 3-4 months on this system, so I’m not sure this has solved the problem or if it will start again soon. However in really appreciate the great responsiveness of the Agenda team!


Ah glad to hear you managed to get it resolved! Apologies again for all the hassle.

1 Like