Spell check doesn’t let me select the changes

What I did: I turned on “Check Spelling While Typing”, “Check Grammar…” and “Correct spelling automatically.” I get a red squigly line underneath the misspelled word or bad grammar.

What happened: when I right click on it to get alternate suggestions the suggestions appear but are greyed out and not able to be clicked/selected.

What I expected: I expected that the context menu would show alternative spellings and then give me the option to select one of them as a replacement. Instead, I had to retype the misspelled word on my own.

Things that might be helpful to know (Agenda version, OS and model, etc): I’m using mojave public beta 10 and Agenda 2.3.

1 Like

Thanks for reporting, we’ll have a look if we can reproduce the issue and fix it.

This is what it looks like for me.

spelling correction from contextual menu is now working in latest update (2.4). Thanks

Great to hear and thanks for letting us know.

So, interestingly, it still isn’t always selectable. I did find that if I click on a mispelled word when it has the squigly underline then a little drop-down box with a spelling correction suggestion appears. This isn’t a contextual menu (ctrl + click), just a click menu. The context menu still isn’t selectable most of the time. Every once in a while I find it is. Very confusing—don’t know when I can expect it to work or not.

Ok, thanks for the follow up, we’ll have a look.

We have a hard time reproducing this, could you perhaps create a screencast showing the issue, or describe a set of reproducible steps?

Reproducing the problem:
Click to edit

  1. misspell a word. 2) Wait for the red underline to appear. 3) single click on the word and wait for a second to see the alternative spellings appear. this works OK, thought it has weird delays and the red underline disspears if you don’t change it and you hvae to click out of the word, wait for the red underline to appear again, and then click on it again to select an alternate spelling.

Right Click to edit

  1. misspell a word. 2) wait for the red underline to appear. 3) right click on the word and then try to click on one of the alternative spellings that are in grey at the top of the contextual menu. This does NOT work; they are greyed out and not selectable.

For me this works fine:


There must be still something else involved. What OS version are you on? And do you have an external mouse? Does it makes a difference if you control+click vs a right mouse click?

I’m also having this in the 2.6 beta (not sure if it worked for me before or not).
On Mojave, internal trackpad. I also created a new user account on my Mac, started Agenda and ran Agenda. Same issue there + I wasn’t able to select Check Spelling while Typing as it was greyed out too (see last attachment here.


From new user account:


Please note that you need to have a note selected (yellow) for these menus to work (at least that’s why the ones in the bottom screenshots in the main menu are not available). If it doesn’t work for selected notes like in the first two screenshots, does it make a difference if you use a control-click vs a two-finger click on the trackpad?

Yes, it does work for a control-click!

I also verified that on the new user account the problem was that I hadn’t selected a note.

Ok, that’s an important hint. Thanks, we’ll have a look.


Maybe I’m not understanding how “correct spelling automatically” should work but taking the name literally this never happens. Basic words like “behalf”, “on” etc. are not corrected “automatically”, nor are suggestions for correcting them made.

Is this a bug or am I missing something? I just switched to “Check spelling while typing”, which appears to do a better job of at least showing me what might be misspelt.

And you are sure you also have enabled the Correct Spelling Automatically option?

1 Like

You’re awesome! I had it selected but it didn’t seem to work before. I just reactivated it and it now works. Thanks.

1 Like