Single Note Content Entirely Missing

What I did:

Made a note on my iPad with a sentence of content.

What happened:

The note appeared on my Mac with the same subject and metadata, but the content is completely empty.

What I expected:

The same content to be in both locations.

Things that might be helpful to know (Agenda version, OS and model, etc):

    I'm running the latest software on my iPad Air and M1 Pro Macbook.

I also attempted edited the note again on my iPad and didn’t see any further updates.

I did create a new note on my Mac and that showed up on the iPad just fine. I also created a new note on my iPad and it synced OK.

Do you still see the note on your iPad, with content?

If so, my guess is that the sync is just temporarily stuck. It probably synced over the title and new note fine, and then a new sync was generated for the sentence you added, and that has so far not worked. I would give it a little time, try making an edit, and see what happens.

If the content is still not synced after some time, you could try copying the note, pasting it to make a copy, and then removing the original. But you really shouldn’t have to do that.

Oh strange. The note did eventually arrive (it must’ve taken a day or so). I’ve only recently started using Agenda and this was a one line note. As long as it eventually syncs, that should be fine, though obviously sooner is better.

We have been seeing a lot of talk amongst developers the last two days that iCloud has some serious issues. I have also seen files take hours to upload in my iCloud Drive.

My suspicion is that you might have suffered from this. iCloud just giving errors for hours at a time.

Not sure what can help in such a case. You could try restarting the device, and hope that triggers some change.