Silly sync season

So I did something silly. Because of a meeting I had to attend, I needed an old Agenda-project. Didn’t know its name so I searched in my Agenda directory, importing and deleting some to and from Agenda on the Mac until I had found the correct file.

Forgot to check iOS which resulted in me, at the meeting, searching the file on my iPad quite energetically but finding nothing. The meeting went well nevertheless (as they always seem to do in the end).

Back in the office, I turned off sync on all devices and turned the Mac back on as soon as the “clouds stopped moving over the islands”. After that had settled down, it was iPad’s turn. But, even after a day and a night of watching clouds, nothing happened. Well, memory usage went up to 20 MB sometimes but soon after, it would drop to 10 or lower.

This made me quite furious.

It was then that I decided to remove Agenda from all of my devices and “try again". This was saturday last and since then, nothing happened. As I’m writing this, my iPad says Agenda is using 18,1 MB.
Agenda MacOS is fine btw.

Of course, I installed the latest regular versions of Agenda.

So just to be clear, your Mac has all the data, and is fully synced (ie no clouds moving)? And you deleted the app on your iOS devices completely, and then installed again?

Do you see the clouds moving on the iOS devices in the right panel?

Usually, this is simply a case of giving the device enough time to upload/download the data. You could hold Agenda in the foreground for a while, just stopping your device from going to sleep, to give it time. If you don’t want to to have to constantly keep the device from “sleeping”, you can turn off the Autolock in the Settings.

Repeat this on each device, letting it sync for around 20 minutes. Usually that will allow everything to upload and download, and it will be fast after that.

If that doesn’t help, here is what I recommend:

  • Turn off the sync in Agenda on each device.
  • It will ask if you want to remove the cloud data. Do that
  • Wait 10 minutes
  • Now turn on the sync for the Mac, and let it finish uploading. The cloud will flash in the right panel, or on the window, until it is done. Can take a bit of time, so you might want to disable sleep or autolock
  • Once it is finished, turn on sync for another device, and again wait until finished
  • Repeat for last device.

If this also doesn’t help, I recommend turning off the iCloud switch in System Preferences/Settings app, and then turning it back on again for the same account. Do that on each device.

Hi Drew,

Thanks. I tried all of your suggestions but for the last one.
I’ll do that in a moment but there’s a warning that says all iCloud files will be removed from the device if iCoud is turned off.
Doesn’t sound good to me or is it not a (next) problem?

I think it will indeed remove the local copies from your device, so it should be a last resort. When you sign back in, it should download them again, but that could take a while too.

There is one more thing we can try before you do that. I am assuming you have all the data on your Mac intact.

OK, so you have all the data on the Mac, right? Here is my suggestion…

  1. Delete the app from the iOS devices
  2. On the Mac, turn off sync in the app, and when it asks, remove the cloud data.
  3. Quit Agenda
  4. Wait 10 minutes
  5. Click on Finder
  6. Choose Go > Go to Folder
  7. Enter ~/Library/Group Containers/
  8. Look for DerivedInfo and drag it to the Trash
  9. Look in PersistentInfo, and drag the files beginning with ChangeSets to the trash (should be 3)
  10. Launch Agenda. Your data should appear after a minute or two. (It has to rebuild the database)
  11. Turn on the sync in Agenda
  12. Wait 20 minutes doing nothing, to let the upload happen
  13. Install on iOS devices, and start the sync

Let me know how it goes.
Kind regards,

1 Like

Turning off sync after a while prompts a message saying it wasn’t possible to remove data from iCloud. “Ok” is the only option to click, after which the sync choice button says “off”.

Update: sorry, I wasn’t clear here. I turn off sync => message: “want to delete data from iCloud?” → me: “yes” => message: "sorry, unable to delete the data … "

1 Like

Hmm. And you have a good connection to the internet?

Perhaps try restarting that device, and then turning on the iCloud sync, and then turning it off again in Agenda. When you turn it off, it should ask if you want to remove the data again. Try that.


Unfortunately, that doesn’t work. The prompted message suggests removing the data from iCloud manually.
The Internet-connection is ok, btw.

Hmm, I guess you can try that then. You can do it manually by going into the iCloud settings in the System Preferences. In there is a “Manage” button I believe, for iCloud Drive. You can find Agenda in the list, and remove the data. Don’t remove the whole app though, because then you can’t use iCloud with Agenda.

After you remove the data, just let it be for an hour or so. iCloud can be very slow handling these deletion requests. After that, try syncing the Mac as described earlier.


Thanks for your support, Drew.
Funny thing is that iPad is now cooperating but only to the point where it all started last week. So the projects I imported then (and removed and re-imported later) are missing. iPhone isn’t cooperating at all.

Your iCloud is not full, I guess(?)

Did you go through the reset on the Mac I mentioned, with the ChangeSets in the trash etc?

Note that often these things are just a question of time. If you have built up a lot of data, that data now has to upload completely, and download completely.

If you see the clouds moving over the islands, it is still busy.


iCloud still has lots of space. And I did that thing with the ChangeSets (though there were four)…
iPad suddenly started loading yesterday. So I then left iPhone open all night but nothing happened, although clouds were moving in.
I’ll give the deleting stuff from iCloud manually a go.

This morning I managed to remove the data from iCloud - only 50,4KB left. Agenda has all projects loaded but the clouds over the islands moved inwards all of the time. Which means receiving from rather than sending data to iCloud, doesn’t it?.
When they stopped, I installed Agenda on iPad to see what would happen. Both instances were showing incoming clouds and unsurprisingly, after a couple of hours, Agenda on the Mac still only has 50,4KB in iCloud and iPad Agenda is still empty.
I also experimented with stopping sync, removing and adding notes in Agenda Mac, restarting etc.

The iCloud member usage number is notoriously slow to update, I’m afraid.

Yes, clouds coming in is incoming/downloading data. Odd that you would see that so long.

I think it would be better to let the Mac fully sync up (upload) before trying things with the iOS devices. The more you fiddle, the more likely it will go wrong.

Try uninstalling the iOS devices again, turn off the sync on the Mac removing the cloud data. If that works, wait 10 minutes, then do the changeset trick over. Do you see the Mac app take a few minutes to load the data again? If so, it worked. Then turn on the sync on the Mac and wait until the clouds stop going to the right.

Sounds like things in iCloud are pretty messed up. At some point your best bet may well be to sign out, and then sign back in. The advantage of that is that your phone will clear away a bunch of locally stored data which is probably causing more harm than good.


1 Like

Hi Drew,

Thanks for all the help but it didn’t work.
This is taking up too much of your and my time, I’m afriad.
Let’s call it a day. Maybe I’ll try again later.



Good afternoon both
This seems to be very similar to my problem. For me, only Agenda on iPhone works. iPad & MAC don’t want to cooperate. Yet (on iPad) I see the clouds over the islands moving happily to sync, but nothing happens.
I just cleaned the cache on MAC and cleaned the laptop with an “installer” recommended by Apple.
Later I shall try again.
Grateful for suggestions, I don’t want to give up!

Good morning, Drew,

So I gave it another go this morning (without the two projects that seem to have caused the problems last week).
The result: looking good. All projects are in Agenda on all devices.
What I noticed: after deleting DerivedInfo and the ChangeSets, starting up Agenda and switching on sync, the clouds were rolling in again, although storage in iCloud was 50,4KB.
After they had stopped, there were no clouds at all. This lasted quite some time. Storage in iCloud grew slowly but steadily though, until it reached ± 45MB. After that it jumped into the GB’s and the clouds appeared. This time they were moving out.

What I don’t understand is why these two projects wouldn’t sync. They were exported as Agenda files about 6 months ago.
As they’re not that big I will just copy/paste their texts in new notes - because I’m not importing them again!

Again: thank you so much for your support!


I’m not sure TBH. They should sync.

I will take a look and see if there is some dodgy logic going on when importing projects. Thanks for the heads up!


One of the files was not exported as an MD file. So I thought … why not!? I imported it.

Everything’s fine.

My best guess is, that importing two or three files and then deleting them shortly after must have corrupted the iCloud data.


1 Like