+ sign followed by space turns into a list (with dash instead of +)

What I did: As a researcher I am trying Agenda as a lab notebook (to replace Findings, a amazing lab notebook for which, sadly, development has been canceled) and in my reports I often use text like this :
20 µl DNA

  • 2 µl ligase
  • 10 µl H2O
    etc …

What happened: When entering the sign + followed by a space, the program change the sign + for a dash : it considers that I am entering a list. And my text thus appears as :
20 µl DNA

  • 2 µl ligase
  • 10 µl H2O

Removing the List formatting of the text remove the dash … but do not restore the + sign.

What I expected: I would like that my + sign stay as a + sign :grinning: Thanks for the help and congratulations for a fantastic software.

Things that might be helpful to know (Agenda version, OS and model, etc): version 13, MasOS11 Big Sur, MBP M1.

Unfortunately at the moment this indeed creates a list. The workarounds at the moment would be:

  • to use the word add instead of a + sign
  • use the fixed width character style (cmd-L) or preformatted paragraph style (cmd-control-5), which also nicely highlights these kind of lists in the text

In the future we also plan to allow escaping of this behaviour.

Thanks for this superfast answer.
I will keep trying Agenda vs other app (Notability, Notebooks) to replace Findings as my lab notebook, but it seems that Agenda is the one that offers the best solution for this purpose (with image and tables options, superscript/subscript, etc…). Also I realized that you can create subcategories in the premium version : I suggest that you mention this possibility in the list of features of the paid version because as I thought at first that it was not available I was considering this to be a negative point compared to other apps.
Thanks again for your help.

1 Like

For what it is worth: on iPad the plus-sign does not change to a List.

Actually it does change to a list also on ipad but only if you add a space after the + sign.
So I guess I will simply avoid adding the space (mac and ipad).
Since this message app appears to behave in the same way I will test it here :
without space : +20
with space : + 20

Nope ! :grinning:

May be it should be in the beginning of the sentence :

  • 20

Yes ! :smile:
Anyway, thanks everybody for the help and I will now remove every spaces from my typing ! :joy:

1 Like

Indeed the list requires a plus followed by a space to trigger the conversion to a list.