Sharing does not work: iPad and Kindle

I tried to share a piece of a text from my kindle, where Agenda is an option. I created a empty not on Agenda, shared the text with the kindle, but the text was not copied in my ipad’s Agenda. The note stayed empty. Could you check whether this is a bug? Thanks.
(Agenda 18.3.2(295) and Ipad 9a generation)

Do you mean you shared it from Kindle app on iPad or iPhone? We don’t have any app on the Kindle itself, so I would be surprised if you could share to Agenda from there.

Can you tell me the steps you took? Something like 1. Selected text 2. Shared 3. Chose Agenda etc


Hello, thanks for the reply.
Let me explain again:
1- I was reading a book in Kindle;
2- Kindle has a menu to share text; I mark a paragraph and asked kindle to
share it;
3- The Kindle’s share command opens the regular sharing menu of Ipad;
4- One of the options of the Ipad sharing menu is Agenda;
5- I had created a note in Agenda to receive that sharing, but it did not
work; the note stayed empty;
6- I repeated the same steps with Things and the text was shared as I
expected, so I suppose that it is a issue in Agenda.

OK, I tried it myself to test. I think I may know what is going on…

When you share, first choose either the image or the text option, and then share, and then Agenda.

Now you see a note. Locate the note you want using the menu at the top.

Now put the cursor in the note, and tap on Insert. Once you have done that, use the Save top-right.

I suspect that you may have missed the insert or the save.

See if that helps. It was working for me fine. (Note you have to open Agenda at some point later before it syncs to other devices.)

Many thanks Drew, it worked. You are correct, I must have missed the “insert” button, maybe because it does not exist when sharing in other software.

Yes, I admit I sometimes do that too. Agenda allows you to insert the content anywhere in any note, and for this reason, we need the Insert button.

Glad you at least figured it out!