Sharing as PDF with URL and images throws error

What I did: I wrote meeting minutes, referenced a website, and pasted two images into the note. I hit the gear in lower right, share, save to files, save to acrobat reader, and save to notability

What happened: save to files popped up a blank white dialog which then closed on its own; save to acrobat reader did nothing; save to notability threw an error dialog: D0A44132-C614-44A5-BF83-EBE80D824562

What I expected: Notes to be stored on files as a pdf, notes to open in acrobat reader, note to be copied to Notability

Things that might be helpful to know (Agenda version, OS and model, etc): Agenda 4.0, IPad Pro 2018; iOS 12.1

It looks like whatever app is accepting this (Notability) is expecting a link, rather than a PDF. Could that be it?

Does this problem happen in all cases, or just a certain note?

I guess you are on iOS, correct?

It might be worth going into Settings app and into Privacy, and check if Agenda has permission to share with other apps.

Kind regards,

Drew- there are no 3rd party apps in my Settings>Privacy section, only Apple stock apps.

OK, try going into the Agenda settings, in the Settings app. There should be some settings somewhere there.

I don’t think so-

Noting that there are 3 scenarios:

  1. Sharing with Files
  2. Sharing with Acrobat reader
  3. Sharing with Notability

Behavior is different in each case and in each case, seems to be in error

  1. Nothing really happens visually, but the file does not appear where it is shared to
  2. NULL white dialog pops up then disappears. File is not transmitted to Reader
  3. The screenshot above

I am new to iOS so I am unsure about how to look for that permission issue.

I just tried exporting notes with attachments to files using PDF, and it worked without issue.

Does it fail for all notes, or just a particular note? If it is just one particular note, any chance of exporting that as Agenda file and sending it to me (


Couldn’t even export it as an agenda file on IOS. Moved to OS X and used export and emailed to you.

Thanks. Got it. I will take a look.

Is the problem only with this one note, or does the sharing not work with any of your notes?

I tried reproducing the issue in a new note and was unsuccessful.

I added images via the Camera functionality surfaced by a long press within the note.

I added link via the text method.

I added the resource tag and a person tag.

In each case I was able to share to Notability as one would expect.

I am not sure what happened to that one note, but I will say it is the first where I tried any of that, and it may be that in the couple of tries it took me to create the link to ‘The Teeneage Brain’, I might have created some corruption. It took a couple of passes and that functionality is ‘active’ within the note in order to convert that format into a usable link. I would look there to see if there are any ghosts gumming up the works.

Not sure what you can see within the file beyond what I can see.

At any rate, since it isn’t coming back as an error, I am satisfied.

OK, glad it isn’t something general. Still be nice to know what was wrong with that one note.