Sharing an image to Agenda from Apollo doesn't work

What I did:
Tried to share an image from Apollo (Reddit client) to Agenda using the share sheet

What happened:
Prompted me to select a note. An entirely empty note was created (neither text nor image)

What I expected:
Add the text and image to the note in a similar way to the Apple Notes app - see attached screen capture.

Things that might be helpful to know (Agenda version, OS and model, etc):
iOS 15.2

We have a more powerful system than Notes. Notes allows you to make a whole new note, but we allow you to put the content in any note, at any location, and even make other edits.

So you are missing one step. You need to hit the Insert button, to insert the shared content. Then it should work. Ie select a point in a note you want to insert the attachment, then press Insert.

Hope that helps!

Thanks. After further investigation it looks like that particular image is causing the share extension to exit (crash?) as soon as I tap Insert.

I’ve tried sharing with some other images and it worked as you described.

Is it a particularly large image by any chance? Looks like a complex PDF perhaps? Any change you could share it with us?

This is the post that contains the image, although I can’t seem to reproduce the problem now. I’ll let you know if it comes up again. Thanks!

Thanks, it might very well be that it hit the memory limit on your device, which can depend on whichever other apps are running at that moment.