Sharing a document with the same note twice fails

What I did:
I copied a Numbers spread sheet with the share option into an existing note. A few days later I updated the Numbers spread sheet and wanted to replace the outdated spread sheet in the note with the updated version.

What happened:
After I selected the note in the share dialog of Numbers, the process aborted without copying the updated spread sheet into the note.
Copying the updated spread sheet to another or new note with the share option worked fine.
Renaming the spreadsheet did not help either.

What I expected:
That the repetitive sharing of a document with the same note is possible via the share option of the document.

Things that might be helpful to know (Agenda version, OS and model, etc):
The problem occurred with both the macOS and iPad versions of Agenda. macOS, iPadOS and Agenda are the latest versions.

1 Like

Sharing of the same document should work fine. I am inclined to think the problem is one of memory: sharing extensions have very strict memory restrictions.

Can you say when the crash happened? Was it when you tapped “Insert”? Does it matter if you first remove the old attachment before tapping “Insert”?

Hi Drew,
I tried it again but with another note and it worked fine indeed. Seems to be the one note that I have the trouble with.
I don’t think it is a memory problem because the note and the spreadsheet are quite small.
The sharing aborts when the note is selected, that is, before the insert. It makes no difference whether I delete the note beforehand or not.

Thanks for looking into it

Some good news in this area, I’ve just finished some major changes to the way we deal with images and attachments which should keep memory much better in check and causes fewer crashes of the sharing extension. Should be part of the next major update.

Thanks for the good news. I’m curious to see if the update fixes this little problem.

Update: I have investigated the problem a bit more. It seems that the problem only occurs when a table is also stored in the note. Could that be the problem?

That’s indeed important info, does it happen with any note that has a table, or only with some?

It happens with all my notes that have already a table stored.

OK, thanks for the follow up, that’s super helpful info, we’ll go after it.

Ok, I’ve found the issue and it will be fixed in the next update, thanks for pointing us in the right direction @Hawe51!

1 Like

Great news👍. Thanks a lot.

1 Like

Hi Alex,
This issue has not been fixed by the last update. Is it still in the works? When can a fix be expected?

All the best

Are you on the 12.0.2 update? And we’re talking about not being able to share any notes with a table in them correct?

Hi Alex,
I am afraid you have misunderstood the problem.
Here is the problem description again:
I have a note that contains a table. If I now try to insert a link into this note, e.g. via the share button in Safari, the share dialog breaks without inserting the link into the note.
If I try to do the same with a note that does not contain a table, everything works fine. And yes, I‘m on the latest version.

So the extension crashes as soon as you try to show the note with the table?

Hi Drew,
Not quite, it crashes as soon as I select the note (in the Agenda share-Dialog) in which to save the link.

OK, and even if the note is small and only contains a single table it does this?

Yes, I tested it with a note, that contained nothing but a small 2x2 table and each cell of the table contained just a single letter.

OK, perfect, thanks, that excludes another possible reason.