Scanning problem

Several related issues here!

What I did:

Scanned around 8 pages in Agenda iOS. Pressed ’save’.

What happened:

‘processing scan’ message, came up. I got on with other work on Mac. When I next looked at iPhone the note was empty.

I thought may be that was too many scans, so I tried again. With one scan, it worked. The image was shown full sized in the note. I tried with a few more pages at one time. It worked, but was shown in note as ‘untitled scan’ icon. Previewing and opening works, but it refuses to show the images in the note.

I was doing the scan to send to some one. So I tried exporting the note to pdf. The first image showed in the note, but the other one just showed as Untitled scan, which wont be much use to my client!

What I expected:

  • scanner not to crash
  • each page of the scan to be shown as an image in the note
  • able to export the note as a pdf with all the images visibel.

Things that might be helpful to know (Agenda version, OS and model, etc):

11.1 iOS

Edited to say: I’ve since completed the same operation in Apple Notes, making all nine scans in one go, and it worked perfectly. I’m guessing Agenda uses the same scanning engine, so thought this might help with diagnoses.

The scanning engine is the same, but the rest is all different. There is no built-in, one click scanning function that everyone can use.

So even if you open the attachment, and send the attachment to your friend, it is not complete?

I will do some testing.

I just did a test on my iPhone 11. I scanned 8 pages. It indeed appears in the text as an untitled scan. This is actually as intended, because large PDFs can only be shown with no preview, to prevent the expense of loading the large file to create the preview image.

So that part seems to work. I then tapped the scan, and it showed the QuickLook preview. I then tapped the “Share” option in the popover, and sent it to myself, and it was fine. (It was around 9MB large).

Am I doing something different to you? When you say you share the note, are you just exporting that as a PDF too? In that case, you won’t get the PDF expanded in the note. You could try rich text with attachments, which at least will put the PDF in and allow it to be opened.

In short, Agenda is not a PDF reader, so it is not going to expand the PDF file pages inline in any print or export. You either have to send the PDF as a separate file, or use something that embeds it, and allows it to be opened (best of all, of course, is an Agenda File).