Right-click menu won’t allow delete a note

delete

#1

When I right-click on a note, and get the note’s context menu, “Delete Note” is greyed out.

However, when I click on the note’s gear icon, and bring up the same context menu, “Delete Note” is enabled.

Expected behavior:
I would expect “Delete Note” to be an option in both context menus.


#2

I think you must be clicking on the note in the “title” area. If you click the note anywhere in the body, the delete note option is in the right-click dialogue box.


#3

I think you must be clicking on the note in the “title” area.

That’s indeed a workaround, we’ll have a look if this can be made more robust.


#4

@zac I just had a look and it actually works for me, are you sure you are using the 2.0? Can you send a screenshot of what you’re describing if so?


#5

Here you go. Not clicking on the title; I can click anywhere in the note, and the “Delete Note” is never available to me. But, when I use the gear menu, it is…


#6

Very strange, it works here. What’s best to do is to see if it’s still a problem in the 2.1 update we hope to release next week or the week after.


#7

Here is my screen with a similar situation:


#8

Tried again in 2.1.1 and this behavior is still broken.

It seems to be largely related to where you click on the note. I’ve noticed (mostly) that if I click in the note body, I can delete the note.

However, if I click in the header area (not on the headline but to the right) or in some margin, non-text areas of the note, many options that should be enabled on the context menu (including delete) are disabled.


#9

I now have two ways to delete the note in 2.1/

  1. Click anywhere in the body, right-click, Delete Note is toward the bottom.

  2. Click anywhere in the body. Hit the DELETE key. A message pops up asking you to confirm the delete

Works very well either way.


#10

Thanks for the additional details, we’ll investigate…


#11

This also happened to me. But it occurs randomly. And I notice that when I click again the note, the “Delete Note” appears. But when I change notes, the option disappears again. Maybe, the option is a little late to react?


#12

We believe this should be fixed in the 2.2 update from last week.