Reminders removed from Reminders app after due date/time

In Agenda 14 (also before?) if I create a reminder in a note in Agenda, assign it a date and time, and assign to one of my Reminders App lists, and then the due date and time passes without the reminder being checked as complete, the reminder disappears from the Reminders App.

If I create a reminder with a due date and time, in the Reminders app itself, the Reminders app does not delete the reminder when it is past due.

I really like the integration of reminders created in Agenda with the Reminders app, but it’s rather freaky that Agenda seems to just delete past-due reminders from Reminders on its own.

Agenda certainly doesn’t tell Reminders to delete it, we’ll see if we can find some answers as to what’s going on.

Can you by the way show/record how you create the reminder exactly and with screenshots show how it progresses? I just checked and added a reminder due yesterday that I didn’t check since that is still there in the reminders app.

Also, are you sure you didn’t check the check list item in Agenda of the line that has the reminder? As this marks the reminder as done as well.

Finally, do you still see the reminder in the reminders app when you Show the completed items? And does the reminder inside Agenda show as checked (gray) or still as due (pink) ?

Apologies, this isn’t true, it’s the other way around, if you mark a reminder as done that is part of a checklist item, then it checks the checklist item. The other way around, checking the checklist item, does not mark the reminder as done currently.

I’ll do some screenshots.

Try installing GoodTask to see if the reminder shows up there. I have consistently found Reminders to display bad data: wrong times, not getting updates, sometimes not showing the task at all. Reminders seems to be the worst client for CloudKit reminders - but Agenda and GoodTask have worked very well for me in that regard.

(It’s ridiculous imo, but that has been my experience)

3 Likes

Thanks for the tip @Pat_Maddox.

Turns out, in a not-untypical tech forum irony, I can not now reproduce the problem. I’ve tried multiple scenarios of reminders in notes not adjacent to text; reminders adjacent to text; reminders adjacent to checklist items; reminders in various projects. Not one case of the “disappearing reminder” encountered.

One thing I do notice, is that only once did Agenda insert an agenda:// link into the reminder in Reminders. I prefer that behavior, but have no idea why it only rarely occurs. All the reminders in the list below were created the same way. Only one received the agenda:// link.

Regarding the agenda link not being inserted, we are aware of one use case where indeed the link is not properly inserted at the moment, we’ll fix that part in the next update.

1 Like

Update: the insertion of Agenda links should now work consistently for Reminders in Agenda 14.0.4

2 Likes

Is it possible to add an option to remove a reminder from Agenda if it is deleted in Reminders, rather than just showing the “missing" icon? I have Things monitoring a list in Reminders, and after Things imports the reminder it is deleted from Reminders. So if I could opt to auto-remove those, I won’t need to cleanup the original note they came from

1 Like

Unfortunately no, Apple’s reminders API implementation doesn’t allow us to determine whether a reminder was really deleted or they stopped syncing part of the reminders (on iOS they only sync a window of x weeks worth of reminders), which means we can’t delete the reminder as we’re not sure it’s actually deleted by the user alas :pensive:

I noticed, that the link will show reminders if “add to selected notes” is selected, but dragging the reminder to the note, while making the link in Agenda, it noes not seem to create a link in reminders. However, once a reminder has been linked to 1 note, the menu for “add to selected notes” or others do not show up any more, so drag and drop seems like the only possible method.
Is there another way to do this?

Also I noticed that the links in calendar are removed, once a note is “unlinked”. But the link in the reminder stays there. Is this meant to work this way?(or an API restriction?)
For reminders, I do not see a similar “Unlink” menu, and right now I just Backspace over the reminder icon in the text. Maybe this is the wrong way to unlink?

Apologies if this was nit picking. I could live without the auto removal, but just wanted to know if it was because I was doing something wrong.

Thnak you

We indeed had a bug where certain links wouldn’t be created, we’ll verify if that’s fixed in the next update. Will also check the reminder link.

The reminders are not working well for me. I am not sure if I do something wrong, but I have really strange behavior.

Where I am:

  • Mac OS 12.5.1
  • Agenda 15 (all updates installed 09/22/2022)

What happens:

  1. I am writing a line in the notes containing a todo
  2. I press the keys Command-Shift-r and come into the dialogue
  3. In the dialog I do not see any reminder-list and I am not able to choose one (I have selected one in the settings to be shown)
  4. I can create now the reminder without selecting a reminder-list
  5. The reminder is created in the wrong list
  6. The reminder contains a link to agenda
  7. I click the agenda link, but the notes are not opened, but just the application is popping up with the last note I opened before

So I have two issues:

  1. I can not choose the right reminder-list. Reminders are always in the wrong list.
  2. I can not refer back from the reminder to the notes as the links do not work

What I would expect:

  1. I am writing a line in the notes containing a todo
  2. I press the keys Command-Shift-r and come into the dialogue
  3. In the dialog the configured reminder-list is prefilled (I only have one, so no reason to choose)
  4. I can create now the reminder in the chosen reminder-list
  5. The reminder contains a link to agenda
  6. I click the agenda link and the note containing the reninder is opened in agenda

Thanks for your help.

Kind regards, Andy