Problem with Sync in Beta

Thanks Drew: I’ve now got the beta version on all iOS devices.

Is there anyway of forcing a full-resync? Both the iOS devices are missing a couple of projects. They are missing the same ones which suggests that the Mac versions (which is what I work on generally, keeping iOS as read-only) haven’t pushed updates to iCloud. However, further testing shows that not to be the case — updates on the MacBook are updated on the iMac within a minute or so; but the iOS versions remain in a partial state. :man_shrugging:

Make sure you have the latest Agenda on all devices. We have now released Agenda 15.

Note that the upload from a device happens after the download. So it is possible that the Mac successfully downloads, getting the iPhone changes, but does not upload properly.

Do you see the clouds over the island icon? If so, the Mac is still syncing. The clouds go to the right when it is uploading.

If you don’t see those, there may be a problem. In that case…

  • Turn off the sync in Agenda on each device.
  • It will ask if you want to remove the cloud data. Do that
  • Wait 10 minutes
  • Now turn on the sync for one of the devices, probably the mac, and let it finish uploading. The clouds will move on the window. Can take a bit of time, so you might want to disable sleep or autolock
  • Once it is finished, turn on sync for another device, and again wait until finished
  • Repeat for last device.

If this also doesn’t help, I recommend turning off the iCloud switch in System Preferences/Settings app, and then turning it back on again for the same account. Do that on each device.

Thanks Drew.

Your message arrived just I was taking leave to go hiking. Back now and it works perfectly.

Thanks again for taking the time to help me through it.

Great to hear it worked in the end!
Best wishes,