Paste as picture

What I did: I copy some cell from Numbers or Excel

What happened: When I paste to the Agenda app. The result is picture

What I expected: I need text format.

Things that might be helpful to know (Agenda version, OS and model, etc): Agenda lastest version on MacOS.

My workflow is exporting file to csv from my online tools. Then I want to organize my result in Agenda. I plan to track result and note idea within Agenda.

Now I must paste in Textedit app and copy to Agenda again.

My suggestion is to have option for paste. The picture is useful in some case and text paste is useful in my case.


I think if you use Edit > Paste and Match Style, it will paste plain text in. Can you give that a try?

Kind regards,

1 Like

This has happened to me too - and just started happening just recently. When I tried to copy a text (from a textbox) in powerpoint, it’s been pasted as an image. When I tried copying the same text to a blank word document, then to agenda, it “pasted” two spaces but not the text.

My guess is that Powerpoint is putting the information on the clipboard in different formats, including text, but also an image. Agenda will tend to look for an image first, and take that.

It’s difficult to get this right for everyone. Copy and Paste doesn’t really offer any control over which data you want to paste in. The only thing you can do is use Edit > Paste and Match Style, which will always try to paste in plain text. Maybe that is a work around.

Kind regards,

I try Paste and Match Style. It works!
But can you add the option with right-click menu. I don’t want to select from menu on the top of screen.

BTW my case is copy muti-cell from Numbers. I don’t try with PowerPoint yet.


Note that Paste and Match Style has a keyboard shortcut. If you want to do it fast, maybe worth learning the shortcut. Putting every menu item in the right click menu could make it very, very long and not practical to use.