One note is out of order

There’s a good chance that I am going to look like an idiot here. But, I’m confused about this:


What I did: Left my computer alone for about a week. Came back, created the new note Aug 2-8, and after syncing completed that’s what I found. I believe the July 20 note was created on a different computer, and hadn’t been synced to my current computer until after I created Aug 2-8.

What happened: July 20 is above the August dates

What I expected: July 20 is between July 17 and Aug 2

Things that might be helpful to know (Agenda version, OS and model, etc):

    macOS 10.15.7
    Agenda 13.1.1

The out of order note appears that way on all my devices.

I have restarted Agenda multiple times. I’ve changed the sort order multiple times - when I have earliest date first, the July 20 note appears at the very bottom. I’ve also pinned and unpinned it.

I will say this: I am looking at the notes, and I am 95% certain that Jul 20 is out of order. But there’s a 5% chance that I’m overlooking something ridiculously obvious.

edit: my “Today” overview was set to July 15. I changed it to today in hopes that it would fix it, but no luck. Also restarted, changed sort order, pin and unpin, etc.

This happened to me a long time ago. Apparently, changing the date on the note that’s out of order fixes the problem, or at least that fixed my problem back then. So, you could change the date on that note to July 31, and then change it back to Aug 2-8.

Apparently, this is a very rare bug that the Agenda folks haven’t been able to figure out. I did many of the same things you did, thinking mine had to be pinned, etc. Changing the date was the thing that finally worked. Hope it works for you!

That’s a simple fix I didn’t think of - and it worked! Thanks :slight_smile:

1 Like

Yeah, have heard about it. Not sure if this was something we had in the past, that was fixed, or not. It might be that we fixed it, but that your note was made prior to the fix. @mekentosj would know more. He works in that area.

Indeed, I have tried to reproduce it but haven’t managed to on my devices. It’s related to having a pinned note or footnote in the same project based on some tests we did with @liz4cps. The workaround is to reassign the date of the out-of-order note indeed. Let us know if you find a way to reproduce the issue.

It hasn’t happened to me again since Apr’19 when I reported it previously. I don’t know if I had any pinned notes in that project; I don’t think I used pinned notes back then much at all, so it seems unlikely. I am using them a lot more now.

I vaguely remember something odd about the date on the note that was out of order, but I can’t seem to remember what it was specifically. I may have tried to set the date by putting 11/28/17 in the title of the note which doesn’t work (apparently, it needs to be 11/28/2017), but I actually wanted it to be 11/16/18, so I’m not quite sure how it wound up being 11/28/2018.

1 Like