Odd periodic refusal to accept dragged file

Periodically Agenda on Mac does not accept files (primarily PDFs) via drag-and-drop.

For example, this morning after starting my computer and Agenda, I tried to drag a pdf from Finder into an existing note in Agenda. The cursor would not appear. I tried dragging from Devonthink and the same thing happened. I worked a while on other things and then tried again and the Agenda accepted the same file from the same Finder window without trouble.

This has happended on my iMac27 with High Sierra and my MAcbook Pro with Mojave.

I have seen this happen some times but it never was related to Agenda, more a system issue where one app had blocked the drag system (for example due to a crash mid-drag). To exclude an issue with Agenda, can you next time this happen drag the exact same file/content from the same app into the Finder or a rich text TextEdit document for example. If it does work there it sounds like an Agenda issue, if it also fails there the system is at fault.