Note background turns black when table inserted on Mac

What I did:
Insert a table into a note on mac
What happened:
the note background turns black and stays black, as if in dark mode (I’m not in dark mode)
What I expected:
the background to not become colored

Even after I go and change the background color from custom (which it becomes after adding table) back to none, the moment I click into the table, the background turns black again.

Basically, tables are un-usable for me now.

A few questions, does this still happen after restarting the app?

Does it always happen or occasionally? Does it make a difference in which note?

Also, do you have the appearance set to follow the system (in the Agenda preferences) and/or is it different from the system preferences?

Hi Alex,
So, indeed restarting did take care of it. I don’t know why I didn’t do that. I kept testing it over and over and it kept doing it. I even created a table on my iiPad, and it was fine. But the minute I opened it up on the Mac it turned completely black. And there was no way to restore it permanently to a non-blackened state. The moment I clicked into it it happened again.

There’s definitely got to be some bug? Right? I can’t imagine that this is just something that my 2018 Macbook Pro running Monterey would just somehow do, and only to notes that have a table. I created dozens of notes and tried this over and over again and kept getting the same result.

In terms of my preference setting, the dark mode/light mode setting is set to system.

Hope that helps.

Once this happens I can understand why indeed it kept appearing, but after the restart it doesn’t return or does it?

You’re correct. It doesn’t return. Or at least it hasn’t so far. I’ve restarted a few times and have been working with tables today. Do you know the cause of this - how it happened at all?

1 Like

Not really, just that the note gets the wrong background color set (probably a bug somewhere in the system) and since this note then joins the pool of reusable cells it will appear when you do actions that refreshes the note, like adding a table.

I encountered a similar issue which was resolved by setting the alpha value of the RTF text background style attribute to 0. Only issue is that the app into which the text is pasted has to provide RTF editing or use the systme font panel. Here’s a script showing a background reset for OmniFocus:

sel =[0].selection
items = sel.databaseObjects.filter(
	item => (item instanceof Project || item instanceof Task)
if(items.length === 1){
	DBItem = items[0]
	noteObj = DBItem.noteText
	runRanges = noteObj.ranges(TextComponent.AttributeRuns)
	runRanges.forEach(range => {
		runStyle = noteObj.styleForRange(range)
		runStyle.set(Style.Attribute.BackgroundColor, Color.RGB(1, 1, 1, 0))