Not able to delete categories in MacOS

Hi Team, here’s the issue I have:

What I did: Tried to delete categories in Agenda / MacOS - Catalina 10.15.4

What happened: Categories do not delete but they delete in iOS for example

Things that might be helpful to know (Agenda version, OS and model, etc): Latest agenda version, Catalina 10.15.4, Macbook pro 15 2017

I would appreciate some help

Can you show which steps you try to take to delete the category on macOS? Perhaps with one or more screenshots?

My pleasure @mekentosj

1- I go to the category I want to delete:

2- I tick those 3 dots (…) and hit Delete Category:

3- Nothing happens: this actually prevents me from deleting any category or subcategory in macOS. I don’t have any issue in iOS.

This may be a long shot, but if you change the name of the category to something other than Archive first, can you then delete it?

In addition to Drew’s question, was the category perhaps an archive before? And if you create a new category, can you delete it?

Thanks a lot for the points guys: so no, it is not because of that. NONE of my categories or subcategories can be deleted. If I change the name, nothing really changes. I will record a short video of the behavior. This is really frustrating :frowning:

Very strange, indeed, could you make a video and email it to

I just uninstalled and re-installed the application and it works now! Argh, should have done this right away. Was driving me crazy. Thanks a lot for being responsive! I love Agenda and want to keep supporting it.

Still, very strange, if you ever hit it again let us know!