“No calendar available” should prompt to connect calendar

calendar
premium

#1

Some onboarding feedback: I purchased premium and then went to preferences to filter my calendars. I got a “no calendar available” error and the Internet Accounts preferences pane popped up. What I actually needed to do was Connect a Calendar first, which I struggled to find for a few minutes. I would suggest adjusting this error/workflow to make things more clear for users who buy premium before setting up the app.


#2

You’re absolutely right and the 2.1 update will exactly do this indeed.


#3

Same problem here. Can’t find Connect to Calendar.
just get the Internet Accounts window pop-up


#4

ok, I found it… that’s really well hidden.
It would be great to have Connect to Calendar in Preferences


#5

As mentioned, the 2.1 update indeed has it there.