Loosing information trying use UNDO function (cmd+z)

What I did:
Accidentalty marking text and continue typing (meaning some of the already typed text was overwritten with some letters)

What happened:
I tried to undo (cmd+z) but nothing happened - the lost text did not come back … this happens from time to time and is really annyoning BUT this time I was analyzing a zoom meeting … investing alredy 45 min to type all nececarry tasks from that meeting into agenda => almost all of my written out tasks in agenda where gone … meaning I have wasted the last 45 min and needed to redo it … guess what: To make sure this would not happen again: I did not use Agenda to type this information … but typed it in notes … just wanted to let you know. If this happens several times a day … Agenda would cause more problems then helping fix them.

What I expected:
Undo function should work and accidentally overwritten text should be replacing the letters that overwrote my notes…

Things that might be helpful to know (Agenda version, OS and model, etc):
Mac with M1, macOS 12.6
Agenda 16.0 (259)

BUT: I am Using Agenda for almost 2 years now … I started with a different mac (which back then still had a intel processor) … back then this issue already happened… . It never felt as bad in the past … and was not worthy the time writing a post like this … because I usually just lost one or two lines of something I simply retyped. But this time I am really ticked because it was „hard work“ getting all this info out of this zoom call … and loosing 45 min of my working time I have invested … just for needing to redo it simply sucks.

I am here reporting this because, I really love agenda. I keep all the client information in there, because it is so helpful to be able to connect the notes with the calendar. I really want it to work - and hope you can fix this bug … so in the future I do not have to fear to loose time again using agenda. Thx.

I’m very sorry that this has happened.

Several years ago, Agenda did have problems with undo, but we spent quite a lot of time on it. It should be much better now, and we don’t hear many reports of issues like we did back in the beginning.

It’s difficult to say why the undo didn’t work in your case. It could be the undo itself, or it could be an internal glitch that affected the editor, including undo (eg pasting).

The problem is it is difficult for us to trace this unless we can make it happen so we can test. If you know a way to get this problem to happen, please let us know. Perhaps you can make a small test project, and try to repeat what you were doing with zoom to see if there is something that triggers it. We could then try to repeat that.

Sorry for the trouble.

Kind regards,

OK - I will simply closer watch it - and if I run into this problem again … I try to reproduce how it happen and let you know asap. Thx.