Keyboard Shortcuts (Apple Magic) iOS

What I did:
I used shortcuts on MacOS, iOS (iPad Pro 2. Gen.) and iOS (iPad 9. Gen.) On iPad with an Apple MagicKeyboard (Bluetooth)

  • to creat a new checklist: cmd-shift-c
  • to end editing a note: cmd-. (On Mac) cmd-< (on iPad)

What happened:

  • shortcuts work great on MacOS
  • mostly on iPad Pro as well
  • don‘t work on iPad (9. Gen.)

What I expected:
That they work as they do on MacOS.
I often use a Keyboard together with the Agenda App on iPad. It would be great to have the same shortcuts working on all devices.

Things that might be helpful to know (Agenda version, OS and model, etc):
The latest on all devices (2022-06-01).
On iPad (9. Gen.) Agenda 14.1.1 with Premium functions :slight_smile:

You will never get complete parity between the devices, because they are completely different systems. Mac has a much more robust keyboard system.

That said, the shortcuts should certainly work on iPad. There is also no difference between iPads as far as Agenda is concerned.

Is it possible the situation was a bit different? What was selected? Could you see the flashing cursor in all cases when you hit the key combination?

Yes of course. It has not to be the same, for sure!

I had the Problem, that shift-cmd-c didn’t work on iPad but on iPad Pro. But right before I tried it again and now it works.
Some others I tried works as well.

So it is my fault – I am very sorry for that!

What still doesn’t work on the iPad (and on the iPad Pro) is the combination to quit editing a note. On iPad it says: cmd-<
But nothing happens, when I try cmd-<
If I try longer, the shortcut cheet sheet appears, because I’m holding the cmd-Key.
The cursor is flashing all the time.

Maybe the wrong shortcut? The language of the iPad is set to German. I tried to set App-Language to English, with the same result.

Thanks for letting us know about that shortcut not working. We will investigate.

Kind regards,

I tried again to use Shortcut cmd-c for checklists.
I recognize that the Shortcuts doesn‘t exist in the German-version [^1] on the iPad but on the English-Version (see the fotos).
So there are definitely other Shortcuts showing in German and English.
But not always. One time it shows shortcuts for editing checklists, and other times it won‘t show these shortcuts. I was editing a note, it showed a flashing cursor and I had set the cursor on a checklist-item: than I tried the shortcuts. I also killed all the other Apps, so that Agenda was the only one that was open.
Maybe I am doing something wrong.

[1]: i.e. language-setting for the App

I think you will find many of the shortcuts on iPadOS adapt to the context. It won’t show any checklist shortcuts if you are not working in a checklist, because the commands would not make any sense (eg “check item” makes no sense without an item).

If I understand the message, you are saying you sometimes get English shortcuts, even though the language of the app is German. Is that right?

Can you explain the exact situation you see the English ones? Eg. What is selected etc? We should then be able to figure out why it is going wrong.

Kind regards,

Yes of course the shortcut-menue depends on the context.

But the thing is, that while editing a note sometimes I am able to use the shortcuts for checklists and sometimes I am not.
I didn’t figure it out, when it works and when not. I tried to switch the language, and that helped in the first place. But I think, that has nothing to do with the problem, because now I have the same problem, and the language is set to English (on iPad).

Concrete (on iPad):
I open a note (p.e. A new one) and begin typing. Then I want set the line as a check-point and use the cmd-c shortcut, but nothing happens. The shortcut cmd-minus for the “bullet”-point doesn’t work either.
And than later (maybe I change to another note or close and reopen the App) suddenly the shortcuts works well.

I don’t know why and when the shortcuts don’t work.

Today I had the following happened (iPad):
I was able to use shortcuts in a note and than change to another note, where shortcuts didn’t work anymore.

I’m sorry, I can’t describe it better!

Is it anything to do with where the cursor is? Eg Does the problem arise when you first make a new note, and are typing on the first line? Or perhaps when you are entering something on the last line of a note?

We are going to investigate in any case. If you notice a pattern, please let us know.

I will try to find a pattern and will let you know.

Till yet, I had the following:

  1. New note, typing text-line, and than tried to convert it to a check-list or a «bullet»-list by shortcuts
  2. existing note, cursor within an existing «bullet»-list and trying to change it to a check-list via shortcuts
  3. New note, empty line and before typing, tried to set it as a check-list via shortcut.

Thanks for investigating. Shortcuts to creat lists are very usefull. Most of the time I use Agenda on MacOs and iOS (iPhone), so it works well. But sometimes I had to work on iPad – so it’s not a hurry, but it would be great, if the shortcuts worked on all devices.

And if I understand properly, you can already see if it will work by holding in the CMD, right? If it shows the correct shortcuts you are alright, and otherwise it won’t work. I guess it is sending the shortcuts to the wrong part of the interface.

If shortcuts are shown in the shortcut-overview (by holding CMD), they work well. Otherwise they aren‘t shown in the overview.