Issue with sharing


I created a very straigtforward shortcut for sharing selected notes to via their API. I tried to use it by sharing a note from Agenda and I found out that something was not right.

I’ve tried in few different scenarios, and it turned out I can’t share the note to pretty much anything other than Apple Notes and DEVONthink.

Once I click the app or choose the shortcut the only way to unblock Agenda is to restart it. I’ve tried to leave it running to check if it’s just something being really slow, but after 45 minutes nothing changed.

I’m on Agenda Version 19.0 (302).

I’m attaching two short clips of how it behaves when failing.

Please kindly assisst :slight_smile:

I’m afraid you’ll have to take this up with the app you’re sharing to, we simply make the rich text available when sharing, it’s the receiving end that needs to process it correctly.

Am I correct in assuming Agenda freezes, ie you can’t interact with it anymore?

I have heard someone else report a similar issue with Shortcuts, and the app freezes.

It’s not freezing per se, I can still use cmd-q to quit. However, I am unable to do anything else, as the app is not taking any input.

If you click on the app and try to type, do you then get the spinning beachball? Or does it just not do anything?

Hi all,
Have the same observation on the last version of Agenda today.
Sharing the markdown or rtf form, etc towards a shortcut, I am getting the grayed-out agenda window. Sharing the same markdown or rtf or note towards (for example) mail or another app (drafts, one note, etc, anything other than Shortcuts) works just as expected.
Tried creating a generic shortcut, with only picking up the content of the share sheet and displaying it, with the same results…
Could very well be an Apple issue rather than an Agenda issue, but worth mentioning, I guess.
Great product, great community !

Attempting typing or clicking anything only results triggering a macOS alert sound, like Agenda is blocked by an open input window or dialog box. Pressing the Escape key or anything else doesn’t help.

Update on my side - running the same shortcut from iOS7iPadOS works as expected, so it appears that it is an issue on the macOS…

Any chance you could post the simple shortcut here, so I can try to reproduce it.

Here is the basic shortcut - nothing to do with Agenda per-se, but for me this one (as the agenda shortcut) works on iOS and not on macOS (the first step is the same as the Agenda shortcut, so if that one does not work, neither will the rest…). Of course, could very well be something directly related to just my setup…

Screenshot 2024-06-05 at 11.21.02

Mine is pretty similar, real-world case is something like this.

@drewmccormack could this have something to do with the 2 lines in the playlist directing files to the .Agenda folder in downloads instead of to the tmp/temporyitems.

In my case, a simple share sheet action is not completed. I believe at this point it has nothing to do with Agenda - even a share from the Apple Notes of a piece of selected text does not make it past the “receive text input from share sheet” step…
BTW, the shortcut to push agenda tasks to Omni works just fine on the iPad or iPhone…