iOS and Mac stopped syncing

sync

#1

What I did: Created new notes in existing projects on both iOS and Mac. Also created new projects on both platforms.

What happened: No changes are synchronising across the devices.

What I expected: Synchronisation of changes.

Things that might be helpful to know (Agenda version, OS and model, etc): iPad Pro, MacBook 2015, latest versions of the app on both. 4.1 on Mac, 4.1.2 on iPad Pro.

Everything was working last week. I’ve tried restarting the app and both devices. iCloud is still enabled on my Mac.


#3

You didn’t happen to disable iCloud drive on either of your machines?


#4

No changes, as far as I’m aware. My MacBook is company owned and connected to a corporate network so it’s possible something’s been changed which I’m unaware of. I’ve only just noticed the lack of sync this morning so I’ve not yet been able to check on my personal iMac at home.

Are there any logs I can check which might shed some light on whether Agenda’s been able to sync or not?


#5

Best is to check at home indeed, it might be that they started blocking iCloud drive at your corporate network :frowning:


#6

iCloud synching is working fine with my personal iMac and my personal iPad Pro. If the root cause is corporate blocking then that will really screw up my use of Agenda! :sob:


#7

We will be adding Dropbox sync soon. Don’t know if that will help you or not.

There are two things that could cause a problem here:

  • They are blocking iCloud
  • You have a different iCloud account on your Work computer

#8

It’s the same iCloud account. I grudgingly signed into my personal iCloud account on my work MacBook just do I could get Agenda working on my personal devices.

Funnily enough, the sync has started working again today. I’ve changed nothing and I’ve no idea whether anything’s changed on the corporate network. Hopefully, this was just a temporary thing, but Dropbox sync would be most welcome too.


#9

Having the same problem on and off here. I changed nothing either. Agenda just stops syncing every now and again.


split this topic #10

A post was split to a new topic: Getting Sync Logs


#11

I am having a similar problem. iOS version on iPad has, for example, 6 projects under a certain category, but only 5 of those sync to the Mac. They all sync to the iPhone. All three devices are running Agenda 5.0


#12

Sounds like the Mac is not downloading the project properly for some reason. You could try signing out of iCloud on the Mac, and then signing back in again with the same account.


#13

Same here. Not contributing with a solution other than to point out this does not appear to be an isolated issue. Notes added to Mac sync with iPhone, but not with iPad. Notes added to iPad sync accross all devices…

All devices connected to iCloud, no coprporate overseers blocking access…


#14

I have signed out of iCloud on the Mac, and signed back in with the same account. Nothing has changed. The Category that has six projects on the iPad and iPhone version of Agenda has only five on the Mac. I tried adding a new note on the iPhone to the “missing” project to see if that might trigger a change, but alas, still nothing changes.


#16

Does it help if you redownload things from iCloud on your Mac?

Don’t do the below unless you are syncing with iCloud and do the backup step outlined below

  • quit Agenda
  • in Go to Folder under the Go menu in Finder, paste:
    ~/Library/Containers/
  • make a backup copy of the com.momenta.agenda.macos folder, then delete it
  • start Agenda

You’ll notice you have an empty library, but it should be populated again from iCloud. This might take a few minutes. Check if after this sync works between all you devices. If it does we would be very keen to receive a zipped file of both the agenda container you backed up before deleting and after it was redownloaded from iCloud.


#21

That worked. The zipped files are too big to upload. How shall I get them to you?