iCloud Sync problem in iOS 17

I have the same problem. Latest MAC OS and iPhone 15 Pro with ios17.

I’m using iCloud (which works perfect with every other app, almost instant sync). Since the day before yesterday, agenda has stopped syncing between the two devices. I’ve signed in and out, added new apple devices (which don’t sync either and folders are missing / never get downloaded), re-installed app, used different Wifi and Cell connections.

I’ve changed nothing on the settings. Agenda Syncing worked well for years. Now some Projects don’t even download/show up anymore. Some project infos on Mac say “edited by this device” while the same project info on the iPhone says “edited by iPhone and Mac”. It’s all gone completely strange!

Btw it seems super random. Like a new project I’d create on the Mac never shows up on the iPhone but 2 hours later some changed line within a different project will sync. In any case super laggy to the point that i can only focus on one device now.

I have now an additional iPad and an old iPhone connected to my Agenda account, just for testing. If I add text on those devices – even though correctly connected and signed in –it does not show up / sync on the new iPhone and the Mac. This happens even when connected to different networks and call/mobile internet. Definitely some syncing problems? Super frustrating.

Any other apps sync instantly including calendars etc. So it’s not an iCloud issue.

It can still be an iCloud issue, even if other apps are working. iCloud keeps track of data separately for each app.

Are any of the devices syncing properly at all? I guess not, right?

For the new devices, they won’t upload their data until they are completely finished downloading the existing data. So if there is a problem, you won’t see the new notes made there.

Perhaps it is best to reset the cloud data, and let it sync up again. If you want to try, this is how…

If that doesn’t help, here is what I recommend:

  • Turn off the sync in Agenda on each device.
  • It will ask if you want to remove the cloud data. Do that — remove the cloud data
  • Wait 10 minutes
  • Now turn on the sync for one of the devices, and let it finish uploading. The clouds will move over the islands icon until it is done. This can take a bit of time, so you might want to disable sleep or autolock to let it finish, and perhaps connect to power
  • Once it is finished, turn on sync for another device, and again wait until finished
  • Repeat for other devices, one at a time

Best not to add test devices. They will just make it worse.

If none of this helps, I recommend turning off the iCloud switch in System Preferences/Settings app, and then turning it back on again for the same account. Do that on each device.