How to turn off autocomplete

What I did: I was typing statements e.g. in marketing

What happened: it autocomplete with some exotic language. When I was typing “in marketing”, it auto complete to give “Ma right e”. There are many other statements that autocomplete to nonsensical words.

What I expected: it should just show what I type.

Things that might be helpful to know (Agenda version, OS and model, etc): iPadOS with Apple Magic Keyboard.

Found the answer. I turned off Hardware Keyboard auto-correct in Settings. Nothing to do with Agenda. But the auto-correct behaves totally different from other apps with the Magic Keyboard.

Odd. So the autocorrect is working with the hardware keyboard in other apps, but not in Agenda?

The hardware Bluetooth keyboard is supposed to autocorrect an incorrect word, not the other way round. In Agenda, paragraph body works fine, but H1 and H2 shows this problem.

One replicable example is the word technology. If you type # This is technology, it will autocorrect to This is Techno Lo gy .

Am I right that you only see this when using the markdown approach? Ie with the #? If you instead choose H1 from the on screen bar, and then type, does it autocorrect properly?

Just tried what you suggested.
No. It produced the same error too.

1 Like

Same problem with Hungarian language. Strange :face_with_raised_eyebrow:

Any chance you could make a quick screencapture of this happening?

Hi. Found the same error but not using the Bluetooth keyboard. Just the onscreen iOS keyboard.

When you activate H1, H2, H3 and H4 and type. The autocorrect kinda screws up.

However when you type using normal text, then convert it to H1-H4, works fine.

What’s interesting is that “technology” by itself does not produce the autocorrect. It needs to be typed with some words.

Also try # This is marketing.

I finally got a chance to look at this, and it doesn’t happen on my devices.

You don’t have any “Text Replacements” set by any chance? You find those in Settings > General > Keyboards > Text Replacements.

What language were you using?