How to disable Markdown

markdown

#1

Hi,

I am trying to save some of the command I use to perform some actions and thus I need to disable the markup (so _ does not make text italic). I tried to use \ to cancel the markup character but that did not work.
Is there a way to deactivate markup for certain string?

Thanks

Olivier


#2

Hi Olivier,
You can use the preformatted paragraph style, or the fixed-width inline style, to escape text. The latter can be activated with CMD-L or back ticks, eg, `Example_of_fixed_width`.


#3

Thanks, it works but I have to insert `` as if I just do blabla it will change the format of the text.


#4

Yes, it is not a perfect solution. Do you have another idea that you would prefer?

Eg. You could type Example\_of, but having that backslash is not very nice.

The backslash could then disappear, but then how would you see that you have escaped that underscore? It would presumably have to appear different.

Note that markdown editors don’t have this problem, because they just leave the slash there.

Anyone else have any ideas how we might allow escaping without modifying formatting?


#5

It would be fine for me to use \ and have it disappear. Using \ is quite natural and well known for IT people but maybe this solution would not be so easy for “non tech” people.


#6

The problem we have then though is that you can’t see that the underscore is escaped. We would have to change its color, or use some other way to show it is special. Otherwise, later, it is possible you wonder why it doesn’t work with another underscore to make italic. Ie you might not realize it is actually a special character.

If anyone has ideas about how best to do it, let us know.

(In fact, with the fixed width option we have now, it does just work as I described above. ie. it gets a different font, so you then know it is effectively ‘escaped’.)


#7

Hi,

Would it be possible to do something similar to Confluence (Atlassian) when you can switch between edit mode with markdown and without markdown.
When editing in markdown mode, you would need to enter \ to escape a markdown but when edit in text mode, all markdown are escaped by default.
I am not used to work with markdown, so for me it feels more natural that nothing happens when I enter a character.


#8

I guess it would be possible, but what we were aiming for was something a bit more organic. We don’t really want to make another markdown editor — there are already many of those.

Many apps using markdown are using it because they are web based, and don’t have much choice. Support for WYSIWYG text editing on the web is pretty prosaic. It’s much easier just to use plain text, and convert that to something that looks nice when you save.

We are trying to be more ambitious. We want nicely styled text, but also the convenience of simple shortcuts that people are used to, hence the markdown. There are still a few rough edges, but we are improving this all the time.

If you don’t want to use markdown, there should be very few moments when it gets in the way. There are a few at the moment, but we have some fixes coming that will help with those too.