How to copy as plain text?

What I did:
Copy

What happened:
Some tag included

What I expected:
I just want to get plain text on the screen

Things that might be helpful to know (Agenda version, OS and model, etc):

Do you mean when you copy out of Agenda, or when you paste into Agenda from somewhere else?

I mean out of Agenda

The standard copy should put plain text on the clipboard. It also puts on rich text, I think, but you can probably use Paste and Match Style to get the plain text pasted.

Are you on Mac or iOS?

I just caputure some movie but I couldn’t put it on this message. “Sorry, new users can not upload attachments.”

If you like, you can send it to me at drew@agenda.com

I met this issue as the command edited in Agenda cannot run in terminal on macOS.
Agenda seems replaced normal spaces to other characters. As in python interactive env:

>>> "mix phx.gen.json Monitors Notice notices group:references:groups machine:references:machines reason:integer "
'mix\xa0phx.gen.json\xa0Monitors\xa0Notice\xa0notices\xa0group:references:groups machine:references:machines reason:integer '

You can see that some spaces pasted from Agenda are ‘\xa0’ though looks like space.
This problem prevent me from using Agenda to keep code snipets.

The space typed in Agenda directly would not have this issue. You need copy-paste codes from VSCode -> Agenda -> Terminal to reproduce. Copy-paste from VSCode -> Terminal directly would not have this issue neither.

Looks like the is pasting in rich text. Have you tried “Paste and Match Style” or similar?

1 Like

Another option is to use the “Copy As > Markdown”.

Thank you! “Paste and Match Style” works! I’ll remember using this.

“Copy As > Markdown” seems the same as the plain copy that not convert ‘\xa0’ back to normal space.