Handling of block quotes: inconsistency between Markdown (or Textbundle) im- and export

That Agenda still has no dedicated block quote style can be worked around simply with indented paragraphs. Which then, quite reasonably!, are exported to Markdown as block quotes (> Lorem ipsum …).

Sadly it does not work the other way round: When importing notes via the File menu on the Mac either from Markdown or Textbundle files, block-quoted paragraphs are not simply indented (and stripped of the leading > ) but kept as such (ie. »> Lorem ipsum …«).

It works better with (at least fenced) code blocks, though, they, too, lose their blank lines, just as with copy and paste.

Related: It’d nice to be able to explicitly tell Agenda that you’re pasting Markdown so that eg. code blocks etc. can be retained then, too. Ulysses does this quite nicely.

And while we’re at it: When copying out Markdown, it’d be nice to have at least an option for fenced code blocks.

Indeed it’s currently in one direction, as you say Agenda doesn’t have the concept of block quotes yet, something we plan to add in a next release.

1 Like

Glad to hear that. Out of curiosity: Will that be a minor release or the next major one, ie. Agenda 15? :slightly_smiling_face:

Major one, possibly Agenda 15 but can’t promise that yet…

1 Like